Compiling Gnome 0.20

Okay, under advice, I've ditched KDE, installed WindowMaker, and I've recently downloaded all the relevant Gnome sources, and have been working my way through the compile FAQ at
Anyway.... I compiled gtk+ and imlib okay, but I had major problems trying to run configure for mico-2.0.5 (let alone making it!), so I downloaded mico-2.1.0 and got that to compile. When running configure, I made sure I used the --with-gtk=<dir> option, and I think I also used the --use-included-gettext option for mico and everything else that would accept it...
However... when I go to make gnome-core-0.20, I get the following error message when panel is being built:
/bin/sh ../libtool --mode=link mico-c++   -o panel  drawer.o gdkextra.o main.o m
enu.o cookie.o swallow.o mico-glue.o mico-parse.o panel.o panel_config.o panel_c
onfig_global.o panel-widget.o panel-util.o mulapp.o launcher.o logout.o gnome-pa
nel.o -L/usr/local/lib -lmicocoss2.1.0 -lmicoaux2.1.0 -lmico2.1.0 -lXt -lgnomeui
 -lgnome -lgnomesupport -ldl -lgdk_imlib -ltiff -lz -ljpeg  -ljpeg -lpng -lz -lS
M -lICE -L/usr/local/lib -L/usr/X11R6/lib -lgtk -lgdk -lglib -lXext -lX11 -lm ..
mico-c++ -o panel drawer.o gdkextra.o main.o menu.o cookie.o swallow.o mico-glue
.o mico-parse.o panel.o panel_config.o panel_config_global.o panel-widget.o pane
l-util.o mulapp.o launcher.o logout.o gnome-panel.o -L/usr/local/lib -lmicocoss2
.1.0 -lmicoaux2.1.0 -lmico2.1.0 -lXt -lgnomeui -lgnome -lgnomesupport -ldl -lgdk
_imlib -ltiff -lz -ljpeg -ljpeg -lpng -lz -lSM -lICE -L/usr/local/lib -L/usr/X11
R6/lib -lgtk -lgdk -lglib -lXext -lX11 -lm ../intl/libintl.a
mico-glue.o: In function `panel_corba_gtk_main':
mico-glue.o(.text+0x24c): undefined reference to `GtkDispatcher::GtkDispatcher(v
collect2: ld returned 1 exit status
Now, I've checked in /usr/local/lib, and there is a libgtk in there.... so I don't understand why it won't work!
Any ideas? Please......
Lee Walton

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]