Re: glimmer 1.99.0

On Sat, 2003-08-09 at 22:32, Robin Cook wrote:
> Getting a configure failure.  Fails on eel says it needs >= 2.3.6 and I
> have 2.3.8 installed.

Urgh. :-( This isn't the most informative problem report I have seen.

For the future, assume that almost nobody will have built glimmer, so
we'll need to see some details from your build log. Also mention what
kind of system you are building against: did you build it yourself from
CVS? did you use scripts from CVS? from tarballs? Are you using
snapshots released by your distributors? ...? With every man and his dog
building GNOME a slightly different way, sometimes there are mistakes
that are unique to a particular installation that we have already seen.
(Of course, it could be possible that the glimmer package is hosed, too.
But I am assuming the maintainer at least did "make distcheck" before
shipping, so that is not the most likely problem).

Now that I've got that off my chest, let's see how far we can get using
the standard techniques...

Firstly, what does "pkg-config --modversion eel-2.0" say? That will be
the version number configure is detecting, so if it is not >= 2.3.6 you
have found your problem (wherever you installed eel is not known to
pkg-config -- you will need to fiddle with the PKG_CONFIG_PATH
environment variable. See the pkg-config(1) man page for details).

Secondly, assuming that is fine, are you really getting a failure with
eel? A lot of pkg-config checks in configure scripts will chekc multiple
things at once and spit out what looks like a big long list of failures.
In fact, only one package will have failed and you may need to read the
line or two before the big list is printed out to find out which package
is really failing.

Failing this, please post the part where configure reports the error,
including 10-15 lines before the pkg-config problem output.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]