Re: [gnome-db] Fwd: gbase64 dependency?

On 9/12/06, Daniel Espinosa <esodan gmail com> wrote:
What about to use a #ifdef / #endif, that put out the code in gbase64.c/h
file if the user has a GLib 2.12. Or even consider not to use the
gnome-db-entry-pict.c at present time, but allows to compile if 2.12 is
present? Is realy necesary that plugin?

I can't say it's necessary! If, as suggested by Rodrigo, you can test
the glib version and bot compile the plugin if it's not 2.12, then
it's Ok (also think to modify the libmain.c in this case).

On a side note, I'll probably do the same with the GtkAssistant which
replaces the GnomeDruid so we can remove the dependency on libgnomeui.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]