RE: [gnome-db] Compiling libgda in cygwin

El mié, 16-04-2003 a las 16:57, Rodrigo Moya escribió:
> On Tue, 2003-04-15 at 13:32, Andres Moya wrote:
> > 
> > This is true. I have changed and not it seems to work! (at
> > least it compiles OK, the next step is trying against a real db. But it
> > will wait until I can compile the whole application using libgda).
> > 
> > Have you corrected this in CVS, or are you going to?
> > 
> I've applied the attached patch, which is different a bit and, most
> important, is the correct one.
> cheers

It's ok, the solution is good, although you have made a small typo: in
the second changed line you have written $(top_builldir) instead of
$(top_builddir). Please fix it.

Now I've found another two issues, probably they have the same cause:

1) When I enable PostgreSQL provide with --with-postgres, the script
does not find it. It's because it looks for '' library
(, line 233), but in Cygwin the only library is 'libpq.a'.

I've managed to compile all by changing this line by hand. :-P

2) When running gda-test, the function gda_config_get_provider_list()
returns an empty list. This is because it looks for libraries in
LIBGDA_PLUGINDIR with extension G_MODULE_SUFFIX. In Cygwin this last
macro is defined as "dll", but the build tool does not generate .dll
versions of the libraries, only .a files. I don't know how to fix this.

Should I send this to Bugzilla?


P.D. The link you sent about Gnome 2 packages in Cygwin is great! I
think that if these two issues are solved (and the other bugs I saw in
gnome-common are solved too), libgda will run perfectly in Windows.

Andres Moya <Andres Moya hispalinux es>

"No a la guerra - Otro mundo es posible"
"No queremos a Bush - Tampoco a Sadam"

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]