Re: Gnopernicus and gnome programs

Hi bill,
I just tried passing the export gtk_modules variable  to gnome terminal
fired up gaim and I got absolutely nothing out of gaim.
What am I doing wrong? I get nothing out of that app.

On Wed, 2005-08-10 at 21:19 +0100, Bill Haneman wrote:
> HI Cody:
> The problems you are having are related but have slightly different root 
> causes.  In order for gnopernicus (or any Gnome accessibility client) to 
> work properly, the application must implement the necessary 
> accessibility interfaces and load a "bridge" through which it 
> communicates to the AT-SPI accessibility framework.  KDE applications 
> don't yet do this, although the KDE team has been working to support 
> AT-SPI in the KDE 4 timeframe.  For best results with Mozilla, you'll 
> need one of the 'Sun builds' of Mozilla, which are periodically 
> published to this mailing list and can be downloaded in source code form 
> and I believe as RPMs for some platforms as well.
> For Gaim, things should work OK for you if you first set a special 
> GTK_MODULES variable in your environment.  There is a distinction that 
> can be made between applications that base their entire user interface 
> on gtk+, and those that depend on more of the Gnome libraries.  at 
> startup if assistive technology support is needed, but the second type 
> of program gets notified automatically "Gtk+-only" or "pure Gtk+" 
> programs (including Gaim) do not.  So to make Gaim work you need to set
> GTK_MODULES=gail:atk-bridge from the command line (the syntax depends on 
> your setup, probably either "setenv GTK_MODULES gail:atk-bridge" or 
> "export GTK_MODULES=gail:atk-bridge" will do it, then start 'gaim' from 
> the same command line.
> You may find more useful information you want in the appendices to the 
> Gnome 2.10 Accessibility Guide:
> Bill
> Hurst, Cody wrote:
> >  Hello I'm having some issues with gnopernicus. I've done my research and
> >google reports that the instant messenger GAIM works with gnopernicus but
> >when i truied to use it, gnopernicus will not read anything. Evolution seems
> >to work fine, but KMail does the same thing as gaim, reads nothing. I can't
> >get to the menu bar, if there is one, and I can't read anything in it. I'm
> >also having issues with Mozilla web browser, and I've also tried conqueror.
> >I can't use anything other then evolution email really. now I haven't
> >upgrade gnopernicus 0.10.4 on my SuSe 9.3 system to v 0.11.4 but I hope it
> >has some improvments. its really a great project they shoujld keep working
> >on.
> >
> >Thanx,
> >
> >Cody
> >
> >_______________________________________________
> >gnome-accessibility-list mailing list
> >gnome-accessibility-list gnome org
> >
> >  
> >
> _______________________________________________
> gnome-accessibility-list mailing list
> gnome-accessibility-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]