[Glade-users] Glade, Red Hat 7.0 and XInitThreads()

Donald McLachlan wrote:


I just joined this list and checked the archive but did not see anything
addressing my problem.  Is there a FAQ for this list?

Glade has a small FAQ at http://glade.pn.org

I was asked to find out why someone's code which built and ran under
Red Hat 6.2 did not run under Red Hat 7.0.

So I built a really simple test program on 7.0 and it worked.  So I
tried rebuilding their code on 7.0.  Regenerated the glade files,
fixed the Makefile, and it worked.

Then I started merging back the changes they had made to main.c.
When I reintroduced XInitThreads() the program stopped working.
I've learned they added this to make their X Windows calls thread safe,
and that it worked under RH 6.2.

Is this a known problem with RH 7.0?  Any work arounds?

RH 7.0 has XFree86 4.0.1 which is known to be a bit buggy, so that may
be the problem.

But it is a bit unusual to call XInitThreads in a GTK+ program.
Do they really need to do that? GTK+ has its own exclusive lock that most
threaded apps use - i.e. GDK_THREADS_ENTER()/GDK_THREADS_LEAVE().


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]