[Glade-devel] One-liner fix.

On Mon, 2003-08-25 at 10:32, Archit Baweja wrote:

Following is a one liner fix. A thing to note is that both functions
glade_widget_class_get_by_name (), and glade_widget_class_get_from_name ()
are supposed to do the same thing (atleast I think so). They why do we have 2
of them? We should remove the old/not-used anymoreone if possible.

Seems right to me and while at it you should also do the same in main.c
(as a matter of fact glade-3 --dump GtkWindow doesn't work at the

On the other hand, even if I'm not a native english speaker, I like the
name *_get_by_name more: I took a look with a couple of quick greps and
in my opinion you can go all the way, remove the current
glade_widget_get_by_name and rename glade_widget_get_from_name.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]