[Gimp-user] Stylus Button Actions Not Working

said xlow:

| Preface: Using a windows 10 machine.
| I got a VEIKK A30 drawing tablet for Christmas and instantly got
| try and draw stuff. I set up the tablet through the input devices
and it
| seems to work fine. I also downloaded the drivers for the tablet in
| order to change what the buttons on the stylus do.

Part of the issue here, maybe, is that GIMP isn't really a
program. It's more an image-editing program. Think Photoshop, not
Draw. There are some drawing aspects to GIMP, but they're more in
of the original purpose of the program.

| I tried changing the buttons using the driver software, but they
| do the same thing in GIMP. The bottom button, closest to the nib,
| up the same window as when I right click with a mouse. The top
| farthest from the nib, allows me to move the page around and zoom
| sometimes, I'm not really sure how the program determines which it
| I've tried changing both button actions and neither seem to change.
| checked online and the stylus does input the correct key
combinations on
| online key checkers.

Do you have an actual drawing or painting program? I know Microsoft
used to
bundle some kind of paint program (I used OS/2 before switching to
22 years ago, so I'm not up to date on Win stuff). Anyway, first 
diagnostic would be to see if your changes work in other programs. If
don't, than it's not a GIMP-specific problem.

That would, seems to me, be something you'd want to try right off the

Thank you for replying. I have tested this out in both Microsoft paint and in
Krita. The changes work perfectly fine there. So far it is only GIMP that is
having this problem. While trying to figure out the problem more I have noticed
that the button actions on the stylus work fine in GIMP if I haven't activated
my stylus in the input devices menu. The problem is it doesn't recognize my
stylus as an input unless I activate it, I.E. it doesn't recognize me touching
my stylus to the tablet as a left click. My current hypothesis, though I admit I
am very ignorant to how GIMP works, is that when I activate my stylus in the
input devices menu it overrides my stylus buttons actions that the driver sets
with its own actions that it assigns to those buttons.

xlow (via www.gimpusers.com/forums)

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]