Re: [Gimp-user] upgrading libpng to => 1.6.25

Am 30.11.2016 um 21:38 schrieb Al via gimp-user-list:
  I'm running ubuntu 16.4, 64bit, and im trying to compile the 2.9.x
latest release from github. I want both 2.8 and 2.9 so I'm not using the
ppa from otto which replaces 2.8.
I can provide a Snap package for you if you want. But be aware I'm not the world's most valuable Snap packager. O:-)

I build 2.9 in a separate dir and did it successfully about 3 months ago
but now
I"ve got a problem.

I've chased the problem down to the requirement for libpng >= 1.6.25
Ubuntu 16.4 uses 1.2.54.

Ive found a package for this libpng-dev_1.6.26-2ubuntu1_amd64.deb and
have it
The problem is when I #sudo apt-get install libgs-dev or any of the
libgdk-pixbuf2.0-dev libgtk2.0-dev librsvg2-dev  libxft-dev

the apt-pkg system reset the libpng-dev to libpng12-dev because that is
a dependency in each of these packages.
If I dont install these packages the make fails looking for
and I'm sure that is just the first error.

What is the proper way to  upgrade the libpng-dev to 1.6.26 so I can
compile 2.9.x?


gimp-user-list mailing list
List address:    gimp-user-list gnome org
List membership:
List archives:

Lao-Tse sagt: Nichtstun ist besser, als mit viel Mühe nichts zu schaffen.
Und er sagt auch: Ich habe drei Schätze, die ich hüte und hege.
Der eine ist die Liebe, der zweite ist die Genügsamkeit, der dritte ist die Demut.
Nur der Liebende ist mutig, nur der Genügsame ist großzügig, nur der Demütige ist fähig zu herrschen.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]