Re: [Gimp-developer] GIMP 2.10 Unable to read tile data from swap

On Wed, May 2, 2018 at 9:59 AM, Ell <ell_se yahoo com> wrote:

On Wed, 2 May 2018 09:16:46 -0400
Partha Bagchi <partha1b gmail com> wrote:

It started again after the final release. It was not there in RC1.

So it only started at some point after RC1, but before 2.10? (days?
weeks?)  I'm trying of think of things that changed during that time
that might have caused this.  Did you change something on your end?

No, I mean that the change was related to the final release 2.10.0 and not
before. I had no reports prior to final release.

My changes are cosmetic. For example, I modify
// #define INSTRUCTIONS_TEXT         _("You can drop dockable dialogs here")
#define INSTRUCTIONS_TEXT         _("")

I don't modify anything in babl or gegl.
My compiler is gcc 7.1

This may be a affect of the transition from gegl 0.3 to 0.4?

Not likely, especially if it already happened before 2.10.  The 0.4
switch happened right before the release.

See above. As you say, 0.4 switch was literally before the final release.
In fact was changed after the release.

In the past, it was related to complicated images with high
resolution and usually setting GEGL_CACHE_SIZE to 2048 or
thereabouts fixed it. Now, it does not.

This sounds like you might have ran out of cache and swap space, in
which case you'd start getting write errors.  These are read errors,
which are much more surprising.

You are right. These are read errors.

I did the following. I set the following environment variables:

It didn't make any difference.

Ok, so it's not the separate paint thread.  That's a good thing :)
What's the rest of your GEGL setup like?  Are you using any other
environment variables?  What's the thread count?

My GEGL compilation of simply what environment variables? I only have one
GEGL variable active now: gpu usage.
My configure from the config.log is:

$ ./configure --prefix=/opt/gimp/std --build=x86_64-w64-mingw32
CPPFLAGS=-I/opt/include -I/usr/python/include -I/opt/SuiteSparse/include
LIBS=-L/opt/lib -L/usr/python/Lib -L/opt/SuiteSparse/lib --disable-docs
--without-libavformat --without-sdl --enable-workshop
build_alias=x86_64-w64-mingw32 CC=gcc CFLAGS=-O3 -ffast-math
-ftree-vectorize CXX=g++ CXXFLAGS=-std=c++14 -DMS_WIN64 -O3 -ffast-math
--no-create --no-recursion

My thread count is 8. I've tried with thread count set to 1 with the same

Matter of fact, GEGL_SWAP was unused.
So, I removed it and reran GIMP. No change.

Do you mean that GEGL wasn't using the swap?  Can you use the dashboard
to see if anything "interesting" is going on while this happens?  Is
the cache full?  Is the swap nearly full?  Do the reported cache/swap
size limits make sense?

OK. When I start the dashboard, I have the following:

Occupied: 0 bytes (0%)

Limit: 7.9 GiB


Occupied: 0 bytes (0%)

Size:         0 bytes (0%)

Limit:        114.7 GiB

CPU (0%)

Opened image (RGB Color 16-bit gamma integer, MelissaRGB 1 layer) 7378x4924
(D800 36MP image)
Duplicate Layer.

Occupied: 751.6 MiB (9%)
Limit:         7.9 GiB

Swap (no change)

Start painting on the layer:

Occupied: 818.7 MiB (10%)

Limit:         7.9 GiB


Occupied: 512.0 Kib (0%)

Size:         4.0 MiB (0%)

Limit:         114.7 GiB

CPU (0%)

But, we have:
GEGL Message

unable to read tile data from swap: No such file or directory (0/130568
bytes read) --

GEGL Message

unable to read tile data from swap: No such file or directory (0/130568
bytes read) --

GEGL Message

unable to read tile data from swap: No error (0/130568 bytes read) --

 Too many error messages etc.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]