Re: [Gimp-developer] configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7

On 2018-07-11 09:59 AM, richard brown via gimp-developer-list wrote:
The latest git pull of 2.99 won't build.  It gives me the error

"configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7"

Ah, but I have appstream-glib >0.7.7 installed; built it from source and installed it into the prefix I use for gimp.

Last night I discovered this (yet another) new dependency required to compile GIMP. I'm still trying to compile it as my distro only has a 0.5 version of the library. I have no idea why it is needed. When I tried to compile it I find it tries to ocmpile with support for RPM packaging. I don't use RPM packaging on my machine.

Richard, I would have said that you need to installed the -dev package of libappstream-glib installed on your machine except you buit-it yourself. I'm trying to compile it myself but it isn't finding the yaml library even though it is installed. If I get my compile to work I can dig in to the problem.


Kevin.               | "Nerds make the shiny things that | distract the mouth-breathers, and
                                    | that's why we're powerful"
Owner of Elecraft K2 #2172          |
#include <disclaimer/favourite>     |             --Chris Hardwick

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]