Re: [Gimp-developer] Compiling GIMP-2.9 with the new mypaint requirements


On Tue, Jan 2, 2018 at 2:25 PM, Tobias Ellinghaus <houz gmx de> wrote:
Am Dienstag, 2. Januar 2018, 14:05:58 CET schrieb Elle Stone:
On 01/02/2018 07:38 AM, Elle Stone wrote:
When configuring GIMP-2.9, it doesn't find the mypaint brushes.

6. So I tried also install the mypaint brushes in /usr/local, but GIMP
still can't find the brushes.

7. In case it's relevant.  I have libmypaint-1.3.0 installed from Gentoo
equery list '*mypaint*'

  * Searching for *mypaint* ...

[IP-] [  ] media-libs/libmypaint-1.3.0:0/0

Installing the brushes in "/usr" allowed GIMP to find the brushes. But
it seems like GIMP should have found the brushes when they were
installed in the prefix.

You probably have to add


I'm not sure why everyone was only adding a lib/pkgconfig/ but
share/pkgconfig/ is also to be added in any custom prefix in
Why it worked inside /usr is because this is already in the defaults
path of pkg-config for the /usr/ or /usr/local/ prefixes but you have
to take care of it for any custom prefix.

Also why can it be in share/ or in lib/? The logic is quite simple: if
this is a library, the pc file goes in lib/pkgconfig/, if this is a
data package, it goes in share/pkgconfig/.
Have fun!


to your PKG_CONFIG_PATH. libmypaint installs to lib/pkgconfig and the brushes
are in share/pkgconfig. Both are valid locations, but this adds one new path
you have to deal with when installing dependencies for GIMP separately.


gimp-developer-list mailing list
List address:    gimp-developer-list gnome org
List membership:
List archives:

ZeMarmot open animation film

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]