[Gimp-developer] Compiling GIMP-2.9 with the new mypaint requirements

When configuring GIMP-2.9, it doesn't find the mypaint brushes.

Following this page: https://git.gnome.org/browse/gimp/plain/INSTALL.in

1. I cloned this:
git clone https://github.com/Jehan/mypaint-brushes.git

2. I switched to this branch:
git branch --list
* v1.3.x

3. I ran these commands:
./autogen.sh --prefix=$PREFIX
./configure --prefix=$PREFIX
make && make install

4. I checked to see if the mypaint brushes were installed, and they were. Here are the installed files:

/home/elle/code-install/gimpdefault/install/share/mypaint-data/1.0/brushes/. . . (with a bunch of brushes in the brushes folder)


5. When attempting to configure GIMP, here is the error message:

./autogen.sh --prefix=$PREFIX --with-gimpdir=$PREFIX/config --disable-gtk-doc --enable-debug=yes

Error: GIMP configuration failed.

  - Error: missing dependency mypaint-brushes-1.0

6. So I tried also install the mypaint brushes in /usr/local, but GIMP still can't find the brushes.

7. In case it's relevant. I have libmypaint-1.3.0 installed from Gentoo portage:
equery list '*mypaint*'
 * Searching for *mypaint* ...
[IP-] [  ] media-libs/libmypaint-1.3.0:0/0

Did I miss some magic step along the way? If not, how do I tell GIMP where the mypaint brushes are?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]