Re: [Gimp-developer] GEGL errors during 'make' process

Hi Americo!

On Sat, Feb 3, 2018 at 2:45 PM, Americo Gobbo <jag rabisco gmail com> wrote:
Hi Tobias,

Hi All,
I have upgrade my system to ubuntu gnome 16.04.3 and I have tried again
compile GEGL. The '' is finished OK, without problems.
The 'make' process have these errors messages:

gcc: error: /usr/local/lib/ No such file or directory
Makefile:571: recipe for target 'gegl' failed
make[2]: *** [gegl] Error 1
make[2]: Leaving directory
Makefile:634: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/jag/devel/gimp-default-master/gegl'
Makefile:541: recipe for target 'all' failed
make: *** [all] Error 2

Someone can give some suggestion?

Is that a fresh git clone or did you compile in the directory before?

I have a made a fresh git clone of 'gegl' and it results the same error...
is a bit odd :-)

Were you building inside the git repository or in a separate
directory? In the second case, make sure the build directory is empty.
Could you send us the contents of "config.log"? Since gexiv2 and exiv2
are looked up with pkg-config, it will allow us to see what was
detected too.

Since you can't attach a file, just copy-paste its contents somewhere,
for instance at


Perhaps, the problem is on my environment setup script?

export PATH=$PREFIX/bin:$PATH
export ACLOCAL_FLAGS="-I $PREFIX/share/aclocal"
export GIO_EXTRA_MODULES=/usr/lib/x86_64-linux-gnu/gio/modules
export SRC_DIR=$HOME/devel/gimp-default-master/gimp-2.9/build
export CFLAGS='-std=gnu99 -fPIC'
export LESS="-F -X -R"

gimp-developer-list mailing list
List address:    gimp-developer-list gnome org
List membership:
List archives:

ZeMarmot open animation film

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]