Re: [Gimp-developer] libmypaint version for building GIMP-2.10.0

On 04/27/2018 07:18:53 PM, Carmelo DrRaw wrote:
Dear all,

I am currently stuck with what seems to be a version dependency conflict between GIMP and libmypaint-1.3.0.

GIMP requires GEGL >= v0.4.0, however libmypaint still requires GEGL v0.3.x:

checking for GEGL... no
configure: error: Package requirements (gegl-0.3 >= 0.3) were not met:

No package 'gegl-0.3' found

This happens because GEGL v0.4.x only provides gegl-0.4.pc

I am using the latest official release of libmypaint: <>

I have applied the following "patches"
With these libmypaint compiles fine.


        sed -i -e'/gegl_required_version/ s/0.3/0.4/'
        sed -i -e's/gegl-0.3/gegl-0.4/g' gegl/
        sed -i -e's/gegl-0.3/gegl-0.4/g' gegl/
        sed -i -e's/gegl-0.3/gegl-0.4/g' gegl/
        sed -i -e's/Gegl-0.3/Gegl-0.4/g' gegl/
        sed -i -e's/Gegl-0.3/Gegl-0.4/g' gegl/
        sed -i -e's/gegl-0.3 >= 0.3/gegl-0.4 >= 0.4/g' configure

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]