Re: [Gimp-developer] libmypaint version for building GIMP-2.10.0


On Fri, Apr 27, 2018 at 7:18 PM, Carmelo DrRaw <aferrero1975 gmail com>

Dear all,

I am currently stuck with what seems to be a version dependency conflict
between GIMP and libmypaint-1.3.0.

GIMP requires GEGL >= v0.4.0, however libmypaint still requires GEGL

checking for GEGL... no
configure: error: Package requirements (gegl-0.3 >= 0.3) were not met:

No package 'gegl-0.3' found

This happens because GEGL v0.4.x only provides gegl-0.4.pc

Which is normal, since it is GEGL 0.4, not 0.3. ;-)

And yes, you are right. The GEGL dependency in libmypaint is GEGL v0.3, and
I am not sure that will change soon, since libmypaint developers are mostly
working on libmypaint v2 now. You can still ask them if they would make a
libmypaint v1 with updated GEGL dep.

BUT for the time being, it is not much a problem because (1) GEGL v0.3 and
v0.4 can be installed next to each other (hence the different namespace)
and (2) you don't have to build libmypaint with GEGL. libmypaint-gegl is
not used by GIMP in any way to this day.
So just build libmypaint with --disable-gegl and don't care about
installing GEGL v0.3.

I am using the latest official release of libmypaint:
v1.3.0/libmypaint-1.3.0.tar.xz <

libmypaint version is right. This is the GEGL version whose version you did
not correctly installed.


Should I use a specific commit instead?

Thanks a lot!
gimp-developer-list mailing list
List address:    gimp-developer-list gnome org
List membership:
List archives:

ZeMarmot open animation film

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]