Re: [Gimp-developer] missing babl fast path and lt-gimp-2.9 segfault

On 07/08/17 03:00, Carol Spears wrote:

On Sun, Aug 6, 2017 at 7:00 PM, Carol Spears <carol spears gmail com <mailto:carol spears gmail com>> wrote:

    On Sun, Aug 6, 2017 at 5:30 PM, richard brown
    <richardbenedict gmail com <mailto:richardbenedict gmail com>> wrote:

        On 06/08/17 21:20, Carol Spears wrote:

        On Sun, Aug 6, 2017 at 1:49 PM, richard brown
        <richardbenedict gmail com
        <mailto:richardbenedict gmail com>> wrote:


        Asking me?

        The babl fast path is probably not the problem, at least it
        is not a problem here. Actually, I kind of like it because I
        can watch it to know where some of the other plug-ins are at
        in their progress.

        The last time I had a segfault like that, I was instructed to
        install gdb (
        <>) because the regular
        stack trace is not so helpful.

        That has been a few years now, so maybe my advice is outdated.

        Thanks.  I tried it, and it doesn't like the "gimp-2.9" script
        that launches the program.

        "/home/richard/Software/gimp-git/gimp/app/gimp-2.9": not in
        executable format: File format not recognised

    gdb is going to want to be started from the command line.

It is weird to me that you are running this from the source file. You don't install into /usr/local or /opt or some such? If you
    have been building and using gimp from there for a long while,
    that would not be the problem but I would have thought that this
    could cause problems, like gimp finding the plug-ins it brings, etc.

    Here is a how-to that doesn't mention anything I remember when I
    used gdb:

    I remember using "bt" something like 'gdb bt /path/to/binary/gimp-2.n'

    If you could get a good output from that, perhaps you could file a
    bug report and maybe the real hackers are there....

After some thought, (and unfortunately no reading) I suspect that the "bt" was typed during the stack trace.

Perhaps there is some reliable advice in the mail list archives....


Got gdb working with it:

[New Thread 0x7fffaeffd700 (LWP 18150)]
[New Thread 0x7fffae7fc700 (LWP 18151)]
[New Thread 0x7fffbcbb0700 (LWP 18152)]

Thread 1 "gimp-2.9" received signal SIGSEGV, Segmentation fault.
g_type_check_instance (type_instance=type_instance@entry=0x1de98880) at gtype.c:4131 4131 TypeNode *node = lookup_type_node_I (type_instance->g_class->g_type);

But, I checked 'Preferences' and I was running 4 threads, and there's a warning there about instability. So, I tried putting that to 1, and, so far, no crash.

>*Schoolboy error*<

But thanks for your help.

(The non-standard prefix stuff that I use to run gimp was outlined here if you're interested:

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]