Re: [Gimp-developer] 2.9 and Linux Mint

Am 23.06.2015 um 05:19 schrieb Alexander Rabtchevich:
Jehan Pagès wrote:

On Mon, Jun 22, 2015 at 9:48 PM, Alexander Rabtchevich
<alexander v rabtchevich gmx net> wrote:

I've just installed brand new Mint 17.2 Mate rc. It has GdkPixbuf
2.30.7 and GIMP requires 2.30.8. Does it mean current development
version of
GIMP will not be available in Linux Mint?
I'm not sure what you are asking for. Since this is a development
version, it requires slightly late version of some libraries, and thus
sometimes not available on some distributions. It does not mean you
can't compile the dev version of GIMP, only that you may have to
compile some of the dependencies.
I am myself a GIMP dev, and I currently use Linux Mint (Linux Mint 17
Cinnamon 64-bit). So there are no problems: you can build GIMP there.
Linux Mint 17.2 is going to be released in a week or two. Its Mate
edition will not meet current GIMP requirements, at least the RC does
not. Does Cinnamon edition contain enough version of GdkPixbuf from
the box?

With respect,
Alexander Rabtchevich

I hope this helps:

Am 16.04.2015 um 16:13 schrieb Mukund Sivaraman:

Hi Thorsten

On Thu, Apr 16, 2015 at 03:53:06PM +0200, Thorsten Stettin wrote:
I've tried to build Gimp 2.9.1 commit
c72bc50e5d1f50eb0ee0a13dbc5d6d9a60dc6e78 on Ubuntu 14.04.
Is GdkPixbuf >= 2.30.8 really essential? I'm heading for disaster.
So much packages depends on GdkPixbuf <= 2.30.7.
It will be a dependency nightmare. 
This was probably bumped for gdk_pixbuf_new_from_resource(). You should
be able to lower it to 2.30.7 and use it. Note that you'll have to make
this change in and app/sanity.c.

Here is my patch:

It works!

I use it in conjuction with gimp-2.9.1 builds at

gimp-developer-list mailing list
List address:    gimp-developer-list gnome org
List membership:
List archives:

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]