Re: [Gimp-developer] Bug 155733 - discussion of approach (bug: need to check return values of gimp_drawable_mask_bounds())

On 01/03/2012 06:49 AM, Neil wrote:
On Tue, Jan 3, 2012 at 2:09 PM, <gg catking net <mailto:gg catking net>> wrote:

    My original comment about sharpen not working seems to have been a local
    problem, that is now fixed. I thought this may be relevant to your issue.

Yeah, it could have been. I tried to reproduce it before I read your second message :)

    If blur does not have a dialog it must be a one size fits all and may as
    well be removed! It clearly is not properly integrated into GIMP if it
    gets listed as "reshow" when it was never shown.

    My earlier bug report here on sharpen showed it got integrated into menu
    as both "reshow" and "redo" even when I cancelled without doing a change.

    These are more like UI defects but I thought it may have something to do
    with dialogue failures not exiting cleanly or at the right time. I could
    not imagine someone adding a blur that was not adjustable, that's just dumb.

I tend to agree that the reshow/redo behaviour feels like a UI bug/misfeature but I'm a novice here - others may feel differently (?). And I was also caught by surprise recently by the blur behaviour - I had thought it had a dialog box but perhaps I have always used one of the other blurs (which does)... Perhaps it's there as a "simple" tool for beginners?
With my version (2.6.11) "Blur" does an uncontrolled blur of about 4 pixels, then in the edit menu provides a "Fade blur" option ranging from 0-100%. This actually works pretty well for a couple of things I did to clean up some garbage pixels.


gimp-developer-list mailing list
gimp-developer-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]