Re: [gdm-list] gdmflexiserver questions

On Fri, May 9, 2008 at 9:37 PM, Reid Rivenburgh <reidr pobox com> wrote:
> 2. I noticed my machine was slowly using up memory.  It seems that
> everytime I run "gdmflexiserver -s", I get a whole new X session
> running.  When I log back in as me, it doesn't go away, so they're
> building up over time.  At the moment, I have six metacity processes
> running (and I run fvwm!), which is how I've been monitoring this.
> I've noticed that when I run "gdmflexiserver -s", it almost
> immediately shows the gdm login screen, but then I see a new X server
> starting, and after a few seconds, I again see the gdm login.  I
> thought at first that it was just killing and restarting the X server
> for some reason, but now I suspect it's creating a new one each time.
> Does anyone know why this might be happening?

I thought I'd post some new info about this problem, in case anyone
has ideas.  I'm still seeing this issue where gdm will start a brand
new session and X server when I run gdmflexiserver (not using "-s"
now).  Symptoms are as described above.  I get this in my xterm:

% ** (gdmflexiserver:384): DEBUG: checking if seat can activate sessions
** (gdmflexiserver:384): DEBUG: Switching to session

** (gdmflexiserver:384): WARNING **: Unable to activate session:
Session is already active
** (gdmflexiserver:384): DEBUG: Started /org/gnome/DisplayManager/Display17

Now I've found that this doesn't happen to either root or a different
normal user on the system, just with my account.  One thing I "fixed"
is that I was setting XAUTHORITY to ~/.xauth in my .zshrc file for
some reason.  I noticed that as a different user, gdm was handling
that itself, creating an xauth file under /var/run/gdm.  Removing the
XAUTHORITY line from .zshrc hasn't fixed the session problem, though.

I have a lot of dot files in my home directory, but I tried
painstakingly moving sets of them aside until the problem went away.
(I of course accidentally lost one set in the process, ugh.)  It
seemed like it did go away at one point, but I wasn't able to
determine which particular file caused the problem.  I moved on, happy
that it was working.  Then the next day the problem came back!  (At
this point, I am missing large clumps of hair.)  I tried copying all
of my dot files to a new test account, but it still worked in the test
account after that.  I'm hoping that someone who knows gdm can tell me
what could be causing this and save me having to go through that

When the second gdm greeter comes up, I can hit ctrl-alt-backspace to
kill that server and it will return me to the original greeter
session.  That's at least a workaround for all of these greeter
sessions piling up on me, I guess.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]