Re: [gDesklets] SlideShow Desklet review

On Fri, 2007-06-08 at 11:33 -0700, Sean Bridges wrote:

> > I was trying to run SlideShow but for some reason it didn't work for
> > me.
> > I put the Control both under ~/.gdesklets/Controls/ and 
> > /usr/lib/gdesklets/Controls but it still can't find the Control.
> > Any clue? 
> I'm not sure.  I installed it on 2 different boxes from the gdesklets
> website and it worked okay. I'm still building my troubleshooting skills
> on these :) One thing I did notice is that I included the pyc files in
> the archive.  I'm just now becoming familiar with how python works.  If
> I understand right these are some kind of byte code compiled files.
> Maybe this can cause issues.  Could you try deleting all the pyc files
> out of your ~/.gdesklets/Controls/ImageSlideShow/ directory and see if
> that fixes it?  That is my only guess at the moment, but will tinker to
> see if anything else comes to light.
> - Sean

So I figured out the issue with my ImageSlideShow control, but not sure
the best way to address.  I installed a fresh Feisty in a VM and got the
same error you reported.  Problem is that I use the python Image library
to read the photo caption data.  I guess this is not installed by
default.  I must have it had installed on my other test systems from
some other dependency :s

Doing an install of the ubuntu python-imaging (sudo apt-get install
python-imaging) package fixes this, but probably not the best method for
a control to have a non-standard dependency.  I will play around with
either removing this dependency, or somehow packaging this library with
the control unless someone has any other suggestions.

- Sean

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]