Re: Grandr and libs problems

I have the same problem and havn't found a solution, including
those mentioned in this thread and
I'm using RH9, gcc-3.2.2-5, XFree86-4.3.0-2, devel & libs. The error I get is below. I can configure and compile grandr_applet-0.2.tar.gz just fine. It's only doing make install in garnome that fails. (Does that help at all?)



==> Running checksum on grandr_applet-0.2.tar.gz
873e08f69d6e2c4d9d433895f3a5dfd4  download/grandr_applet-0.2.tar.gz
file grandr_applet-0.2.tar.gz passes checksum test!
       [checksum] complete for grandr_applet.
install -d work/main.d
==> Extracting download/grandr_applet-0.2.tar.gz
       [extract] complete for grandr_applet.
       [patch] complete for grandr_applet.
==> Running configure in work/main.d/grandr_applet-0.2
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets $(MAKE)... yes
checking for working aclocal-1.4... found
checking for X... libraries /usr/X11R6/lib, headers /usr/X11R6/include
checking for gethostbyname... yes
checking for connect... yes
checking for remove... yes
checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking for pkg-config... /usr/local/garnome27.1/bin/pkg-config
checking for libgnomeui-2.0 libpanelapplet-2.0... yes
checking GRANDR_APPLET_CFLAGS... -DORBIT2=1 -pthread -I/usr/local/ garnome27.1/include/libgnomeui-2.0 -I/usr/local/garnome27.1/include/ libgnome-2.0 -I/usr/local/garnome27.1/include/libgnomecanvas-2.0 -I/ usr/local/garnome27.1/include/gtk-2.0 -I/usr/local/garnome27.1/include/ libart-2.0 -I/usr/local/garnome27.1/include/gconf/2 -I/usr/local/ garnome27.1/include/libbonoboui-2.0 -I/usr/local/garnome27.1/include/ glib-2.0 -I/usr/local/garnome27.1/lib/glib-2.0/include -I/usr/local/ garnome27.1/include/orbit-2.0 -I/usr/local/garnome27.1/include/ libbonobo-2.0 -I/usr/local/garnome27.1/include/gnome-vfs-2.0 -I/usr/ local/garnome27.1/lib/gnome-vfs-2.0/include -I/usr/local/garnome27.1/ include/bonobo-activation-2.0 -I/usr/local/garnome27.1/include/pango- 1.0 -I/usr/local/garnome27.1/include -I/usr/local/garnome27.1/include/ freetype2 -I/usr/local/garnome27.1/lib/gtk-2.0/include -I/usr/local/ garnome27.1/include/atk-1.0 -I/usr/X11R6/include -I/usr/local/ garnome27.1/include/libxml2 -I/usr/local/garnome27.1/include/panel-2.0 checking GRANDR_APPLET_LIBS... -pthread -Wl,--export-dynamic -L/usr/ local/garnome27.1/lib -L/usr/X11R6/lib -lpanel-applet-2 -lgnomeui-2 - lSM -lICE -lbonoboui-2 -lxml2 -lpthread -lz -lgnomecanvas-2 -lgnome-2 - lpopt -lart_lgpl_2 -lpangoft2-1.0 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0 -lbonobo-2 - lgconf-2 -lgnomevfs-2 -lbonobo-activation -lORBit-2 -lgobject-2.0 - lgthread-2.0 -lm -lgmodule-2.0 -ldl -lglib-2.0
checking for XRRSetScreenConfigAndRate in -lXrandr... no
configure: error: "Suitable Xrandr extension library not found - you need at least X 4.3"
make: *** [configure-work/main.d/grandr_applet-0.2/configure] Error 1

On 10/29/2003 12:49:59 PM, Michael Closson wrote:
In general you probably can't make a shared library from the .o's of
archive.  They need to be compiled with the flag -fPIC to be in a
library..  Although it might work, you never know.

In any case, just because you can't list the symbols in a library
doesn't mean you can't link to it.  What is the error you're getting
while building grandr_applet?


On Wed, 2003-10-29 at 00:44, flemingb wrote:
> Thanks Mike,
> I tried what you said - All I have are 2.0 libs for Xrandr. I looked
in the
> libXrandr.a file, though, and extracted the static library from it -

> ar -x libXrandr.a Xrandr.o
> and then compiled that into a shared library
> gcc -shared -o Xrandr.o
> and then renamed it to and redid the other (.so,
> symlinks to point to that file, and then ran
> ldconfig and
> ldconfig -n /usr/X11R6/lib
> I can do a nm | grep "XRRSetScreenConfigAndRate" now
and get a
> valid result, but after running make clean & make in the
grandr_applet directory,
>  I still get the same exact problem. (all that stuff may have been
> though :) Any other ideas? Does RedHat (or someone else) have
different versions
> of XFree86-libs rpm?
> Thanks again,
> Ben
Michael Closson <mclosson speedymail org>
garnome-list mailing list
garnome-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]