Re: Grandr and libs problems

In general you probably can't make a shared library from the .o's of an
archive.  They need to be compiled with the flag -fPIC to be in a shared
library..  Although it might work, you never know.

In any case, just because you can't list the symbols in a library
doesn't mean you can't link to it.  What is the error you're getting
while building grandr_applet?


On Wed, 2003-10-29 at 00:44, flemingb wrote:
> Thanks Mike, 
> I tried what you said - All I have are 2.0 libs for Xrandr. I looked in the
> libXrandr.a file, though, and extracted the static library from it - 
> ar -x libXrandr.a Xrandr.o
> and then compiled that into a shared library
> gcc -shared -o Xrandr.o
> and then renamed it to and redid the other (.so, .so.2)
> symlinks to point to that file, and then ran 
> ldconfig and
> ldconfig -n /usr/X11R6/lib
> I can do a nm | grep "XRRSetScreenConfigAndRate" now and get a
> valid result, but after running make clean & make in the grandr_applet directory,
>  I still get the same exact problem. (all that stuff may have been worthless,
> though :) Any other ideas? Does RedHat (or someone else) have different versions
> of XFree86-libs rpm?
> Thanks again,
> Ben
Michael Closson <mclosson speedymail org>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]