Re: Grandr and libs problems

This is what the script says:

...configure stuff...
checking for libgnomeui-2.0 libpanelapplet-2.0... yes
checking GRANDR_APPLET_CFLAGS... -DORBIT2=1 -pthread
-I/root/garnome/include/libgnomeui-2.0 -I/root/garnome/include/libgnome-2.0
-I/root/garnome/include/libgnomecanvas-2.0 -I/root/garnome/include/gtk-2.0
-I/root/garnome/include/libart-2.0 -I/root/garnome/include/gconf/2
-I/root/garnome/include/libbonoboui-2.0 -I/root/garnome/include/glib-2.0
-I/root/garnome/lib/glib-2.0/include -I/root/garnome/include/orbit-2.0
-I/root/garnome/include/libbonobo-2.0 -I/root/garnome/include/gnome-vfs-2.0
-I/root/garnome/include/bonobo-activation-2.0 -I/root/garnome/include/pango-1.0
-I/root/garnome/include -I/root/garnome/include/freetype2
-I/root/garnome/lib/gtk-2.0/include -I/root/garnome/include/atk-1.0
-I/usr/X11R6/include -I/root/garnome/include/libxml2
checking GRANDR_APPLET_LIBS... -pthread -Wl,--export-dynamic -L/root/garnome/lib
-L/usr/X11R6/lib -lpanel-applet-2 -lgnomeui-2 -lSM -lICE -lbonoboui-2 -lxml2
-lpthread -lz -lgnomecanvas-2 -lgnome-2 -lpopt -lart_lgpl_2 -lpangoft2-1.0
-lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangoxft-1.0
-lpangox-1.0 -lpango-1.0 -lbonobo-2 -lgconf-2 -lgnomevfs-2 -lbonobo-activation
-lORBit-2 -lgobject-2.0 -lgthread-2.0 -lm -lgmodule-2.0 -ldl -lglib-2.0
checking for XRRSetScreenConfigAndRate in -lXrandr... no
configure: error: "Suitable Xrandr extension library not found - you need at
least X 4.3"
make: *** [configure-work/main.d/grandr_applet-0.2/configure] Error 1

I have
and Xrandr.h is in /usr/X11R6/include/X11/extensions

> In general you probably can't make a shared library from the .o's of an
> archive.  They need to be compiled with the flag -fPIC to be in a shared

That might explain why my ghetto lib didn't work. 

> In any case, just because you can't list the symbols in a library
> doesn't mean you can't link to it.  What is the error you're getting
> while building grandr_applet?

> Mike

> On Wed, 2003-10-29 at 00:44, flemingb wrote:
> > Thanks Mike, 
> > I tried what you said - All I have are 2.0 libs for Xrandr. I looked in the
> > libXrandr.a file, though, and extracted the static library from it - 
> > ar -x libXrandr.a Xrandr.o
> > and then compiled that into a shared library
> > gcc -shared -o Xrandr.o
> > and then renamed it to and redid the other (.so, .so.2)
> > symlinks to point to that file, and then ran 
> > ldconfig and
> > ldconfig -n /usr/X11R6/lib
> > 
> > I can do a nm | grep "XRRSetScreenConfigAndRate" now and get a
> > valid result, but after running make clean & make in the grandr_applet
> >  I still get the same exact problem. (all that stuff may have been worthless,
> > though :) Any other ideas? Does RedHat (or someone else) have different versions
> > of XFree86-libs rpm?
> > Thanks again,
> > 
> > Ben
> -- 
> Michael Closson <mclosson speedymail org>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]