Re: [SuSE 8.0] Build possible

Olaf Bergner (olaf bergner gmx de) wrote:
> I spent roughly 20 hours trying to build Garnome on my SuSE 8.0 box. Here's a 
> by no means complete sketch of what I tried:
> 1) Tried a vanilla install of Garnome, went into the meta/gnome-desktop dir, 
> did "make" and surrendered my fate to the powers that be.
> 2) I had some minor issues to resolve involving some libraries not installed/
> not in the right places. Well, I have seen worse.
> 3) Oops, when building libcroco my good'ol gcc 2.95 started to complain about 
> some undefined variables already referenced. I had a short look at the 
> offending code, but not being a C hack I didn't dare to touch it. Looked OK 
> to me, though.
> 4) Well, I googled and lo and behold: libcroco meanwhile seems to require gcc 
> 3.x. But it's not a required library. So I erased it from the Makefile. On 
> with the show.
> 5) Another compilation error, a real one, not one of those funny linker/
> include probs I have grown fond of. Don't recall the module, but this one's 
> serious. Garnome won't work without it. And Google says its gcc 2.95 again.
> 6) Got GCC 3.3.1, configured it, ran make and installed it in a safe place far 
> off my regular programs. Had to tweak my LD_LIBRARY_PATH, but that's about 
> it.
> 7) Recompiled. At first only some minor issues. Gnopernicus turned out to be a 
> real showstopper, what with all the CLASSPATH issues. So no Gnopernicus. 
> There's worse in life.

There was a fix for this in some previous thread.  I forget what it is offhand

> 8) OK. Epiphany wants a current mozilla build installed. And it wants the 
> headers. Tried a recent SuSE mozilla-devel rpm. F.., linked against glibc 
> 2.3. Tried a mozilla 1.4.0 rpm which is not linked against glibc 2.3. Well, 
> it's compiled with gcc 2.95 which makes my shiny new gcc 3.3.1 choke when 
> trying to link.

Yeah, this is common when building from source with a newer version than all the
libraries on your machine are.  There are only a few libraries with this trait,
though.  Mozilla happens to be one of them.  I know glibc is another, but am not
sure you would want to upgrade that:)

> 9) Got the mozilla 1.5b sources and compiled those with gcc 3.3.1. Then tried 
> to rebuild epiphany several times. Some strange problems with libIDL not 
> being found. Had to manually adjust a Makefile under /mozilla/embed or so.
> 10) Finally, I gave up. Prototype mismatch between mozilla and epiphany, it 
> seems. One of those "...candidates are ..." lines. Do I have the wrong 
> mozilla version?

Usually these are in a file due to an:
#if version > 8
nsresult NSCollectInformation(nsInt i) {
return null
or something.  Try changing the if statement to read:
#if 0
Note that the above is just a random function I made up, and doesn't really
exist.  But if you have the entire error, it will tell you exactly where the 
build fails.

> So one short question after a long text: Is there anybody out there who 
> managed to compile Garnome on such an ancient OS as my SuSE 8.0 seems to be? 
> And if yes, what do I have to do to accomplish such an extraordinary feat? I 
> don't mind getting my feet wet, but there's got to be a silver lining on the 
> horizon.
> Thanks,
> Olaf

Good luck,

Samuel Stringham

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]