Re: [SuSE 8.0] Build possible

[ note to Jeff: please re-uncomment the Mozilla dependencies in the next

> 8) OK. Epiphany wants a current mozilla build installed. And it wants the 
> headers. Tried a recent SuSE mozilla-devel rpm. F.., linked against glibc 
> 2.3. Tried a mozilla 1.4.0 rpm which is not linked against glibc 2.3. Well, 
> it's compiled with gcc 2.95 which makes my shiny new gcc 3.3.1 choke when 
> trying to link.
> 9) Got the mozilla 1.5b sources and compiled those with gcc 3.3.1. Then tried 
> to rebuild epiphany several times. Some strange problems with libIDL not 
> being found. Had to manually adjust a Makefile under /mozilla/embed or so.

Which libIDL was it trying to link against? - I had this problem on a
SuSE box a while back where Mozilla found the system ORBit first and
linked there, without success.

Quick, hackish solution in 0.26.2 was to re-export PATH so my GARNOME
directory was before /usr/bin and LD_LIBRARY_PATH so the libs directory
was before /usr/lib and /usr/local/lib -- then run make clean and build



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]