Re: Cannot build F-spot from tarball.


ubuntu provides special packages for the compilers:

please check, if the package mono-mcs is insatlled.


P.S.: What hardware is not supported by 8.10 but by 8.04?

Am 08.01.2009 um 14:36 schrieb Dotan Cohen:

2009/1/8 Stephane Delcroix <stephane delcroix org>:
hey Dotan,

nice to hear back from in you in those troubled times.

Thanks, Stephane. So far for my beautiful family the trouble hasn't
come close to home, but for our neighbors (on both sides of the
border- they are both our neighbors and we worry about them as well)
the situation is getting troubled to say the least. Pray for them, and
pray that they get a government who's goal is welfare and production,
not terror.

install mono-devel package, that should solve your issue.

I tried to install the mono-devel package, but that does not seem to
provide the C# compiler that F-Spot wants:

$ sudo apt-get install mono-devel
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package mono-devel

$ apt-cache search mono | grep dev
libmono-dev - libraries for the Mono JIT - Development files
libslang2-dev - The S-Lang programming library, development version
libxpm-dev - X11 pixmap library (development headers)
mono-1.0-devel - Mono development tools for CLI 1.0
mono-2.0-devel - Mono development tools for CLI 2.0
python-all-dev - Package depending on all supported Python development packages
x11proto-core-dev - X11 core wire protocol and auxiliary headers
libslang1-dev - The S-Lang programming library, development version
libslang1-utf8-dev - The S-Lang programming library, development
version with utf8 support
mono-tools-devel - Various development tools for mono
monodevelop - C/C++/C#/Boo/Java/Nemerle/ILasm/ASP.NET Development Environment
monodevelop-nunit - NUnit plugin for MonoDevelop
monodevelop-versioncontrol - VersionControl plugin for MonoDevelop
monodoc-banshee-manual - Audio Management and Playback application
(developer documentation)

I installed mono-2.0-devel mono-1.0-devel monodevelop libmono-dev
mono-tools-devel however I still get the same error at the end of
checking for MONO_DEPENDENCY... yes
checking for al... /usr/bin/al
checking for mono... /usr/bin/mono
checking for mcs... no
configure: error: No C# compiler found
configure: error: ./configure failed for gio-sharp

Might Ubuntu 8.04 not provide the necessary dependencies? The latest
*buntu does not support my hardware but if I know exactly which
mono-devel I need then I could google for it. I could not find that
info on the F-spot website.

Dotan Cohen

א-ב-ג-ד-ה-ו-ז-ח-ט-י-ך-כ-ל-ם-מ-ן-נ-ס-ע-ף-פ-ץ-צ- ק-ר-ש-ת ا-ب-ت-ث-ج-ح-خ-د-ذ-ر-ز-س-ش-ص-ض-ط-ظ-ع-غ-ف-ق-ك-ل- م-ن-ه‍-و-ي А-Б-В-Г-Д-Е-Ё-Ж-З-И-Й-К-Л-М-Н-О-П-Р-С-Т-У-Ф-Х- Ц-Ч-Ш-Щ-Ъ-Ы-Ь-Э-Ю-Я а-б-в-г-д-е-ё-ж-з-и-й-к-л-м-н-о-п-р-с-т-у-ф-х- ц-ч-ш-щ-ъ-ы-ь-э-ю-я
F-spot-list mailing list
F-spot-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]