database version problem

I know I did this to myself, but I'm hoping there is some way to recover without losing all my tags.

I was running f-spot with no problems, on a Kubuntu box (Hardy) where it is the most recent version available. Through some poor choices of config and nfs mounts, I ran an instance of against the same files. Apparently it upgraded photos.db to a newer version of sqlite3, since when I run the version now, it complains about the database possibly being a more recent version. (Note also that particular message is ONLY to the console - the pop-up doesn't give any reason for having to create a new photos.db.) Anyway - is there any way to convert the newer version to a database that will use? I tried converting to a sqlite 2 database (edit the dump to remove the sqlite_sequence and the autoincrement) but when I run f-spot against that, it converts it to sqlite3, and then says its a more recent version of the database anyway. Is there any hope?

Thanks for any hints or suggestions, even if it's just "start tagging again...."


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]