Re: [Evolution] OAuth2 secret not found and gmail

On Wed, 2021-10-27 at 09:37 +0200, Milan Crha via evolution-list wrote:
On Tue, 2021-10-26 at 17:57 -0700, Van Snyder wrote:
I have no idea where to paste that into Evolution. An offer to save a
password in my keyring is not presented.

there's no place to paste it in, the whole process is supposed to run
inside the credential prompt.

What can I do when the credential prompt doesn't work? As remarked in the original message, the pop-up says "Login to google..." with a grey box and a URL, which rapidly disappears. Then the grey box is filled with an invitation to log in to google, in which nothing works. Any keystroke or mouse click erases the "log in to google" frame, leaving a grey pop-up only with "Log in to google..." and the URL pane erased.

I  can't send a screenshot of it having the "Sign in to google" invitation below the empty URL pane because any keystroke, including "Print Screen" erases it.

That it misbehaves is suspicious. Did you
update WebKitGTK recently?

I have not updated WebKitGTK explicitly. I was unaware of its existence and role until I read this message. I ran "apt-get update". One is recommended to do this frequently. I haven't examined the long log to determine whether WebKitGTK was part of the update.

I do not know how Debian names it, maybe
webkit2gtk3 or any other name. I would try to downgrade it.

Downgrading things in Debian is an invitation to get version conflicts, so that many things suddenly stop working.

Did you replace an existing value in the Seahorse or the key was not
there at all?

There was a key in Seahorse when one gmail account was not working, but not others. Every time I go to google to get a new key, it's different. I replaced the not-working one in Seahorse, and it still doesn't work. And there's no entry in Seahorse for the other not-working gmail account.

If you replaced it, then it's too late to restore to the
previous state. The "OAuth2 Secret not found" can also show when the
evolution-source-registry, or better the  libsecret, lost connection to
the gnome-keyring-daemon.

There was no additional information below "OAuth2 Secret not found" -- just a grey box that fairly quickly filled with the invitation to log into google, in which nothing worked.

There usually helps:
   $ evolution --force-shutdown
which restarts Evolution and all the evolution-data-server processes,
thus they reconnect to the (new) gnome-keyring-daemon and other
background processes, which could restart meanwhile.

I've done that, and rebooted, several times.

For my accounts, when they want a password, there is a pop-up to provide a password. For gmail accounts, all that's produced is the non-working window that invites me to log in to google and get something to "paste into your application." Is there a special reason that Evolution produces a pop-up to request a password only for, and not for


evolution-list mailing list
evolution-list gnome org
To change your list options or unsubscribe, visit ...

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]