Re: [Evolution] Connect Evolution to Exchange 2016

Hi Michael,

thanks for your response,

On 07/22/2018 11:40 PM, Michael Hirmke wrote:
Hi René,

hopefully, I'm at the right place here:
I'm trying to connect Evolution to an Exchange 2016 server.
I have that constellation up and running here.
Exchange 2016 CU10 and Evo 3.28.4 on openSUE Tumbleweed.
To rule out my Evolution installation, I installed openSUSE  Tumbleweed
in a VM but got nearly the same result. Attached is a log from this VM.
It is interesting, that Evolution succeeded after some time to retrieve
the list of eMails from the Server but when I try to open one of these
mails, I again get the "Authentication failed" error.
Some requests seem to succeed while others fail.

Adding the account in Evolution seems to work and also the folders
(including the number of unread messages) are listed. As soon as I
select a folder, I get the error:
Failed to refresh folder ?Exchange : Posteingang?.
The reported error was ?Authentication failed?.
What does the event log on your Exchange server and/or Domain Controller
I need to check this with the Exchange administrator. Unfortunately, I
do not have access to that log.

Attached is the output of
EWS_DEBUG=2 /usr/lib/evolution/evolution-source-registry
My system is an Ubuntu 18.04 with Evolution (including evolution-ews)
3.28.1 and libsoup2.4 2.62.1 installed.
I already tried to
 - move /usr/bin/ntlm_auth away
 - uninstall samba
 - uninstall winbind
 - install evolution-ews from master
 - install libsoup from master
I'm don't know for sure, but AFAIK there is no dependency between Evo
and samba/windbind or ntlm_auth.
Only libsoup is amongst the requirements for evo and evo-ews.
I've read here that moving ntlm_auth away helped solving similar issues:
Not in my case.

Is this already a known issue? Should Evolution work together with
Exchange 2016? What else can I do to debug the issue?
You have to look at your Exchange settings, especially the requirements
for Outlook Anywhere. You have to check the correct names of the server
you use in Evo for connection and the correct authentication method,
i.e. either "ntlm" or "negotiate".
You also have to check your AD user for permission to use Outlook on the
web under recipients in ECP.
Is Exchange under your control or do you have to ask an admin?
I will try to do this with an Exchange administrator.
I can login into Web access (OWA) and other users are able to access
Exchange through Outlook. Therefore, I don't think it is a general
problem with Exchange or with my User. Do you have an idea of which
settings in Exchange could cause only Evolution to behave strange?

Thanks in any case

Attachment: ews_debug
Description: Text document

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]