Re: [Evolution] IMAP Folders disappear

On Wed, 2015-07-22 at 12:21 +0200, Andrea Vai wrote:
Il giorno mer, 22/07/2015 alle 10.37 +0100, Patrick O'Callaghan ha
On Wed, 2015-07-22 at 10:30 +0200, Andrea Vai wrote:
Il giorno mar, 21/07/2015 alle 17.32 +0100, Patrick O'Callaghan 
On Tue, 2015-07-21 at 15:33 +0200, Andrea Vai wrote:
Don't know if it matters, but that "no such table" message 
be related to the problem.

Possibly a corrupt database. Try stopping Evolution (using -
-shutdown) and running:

cd ~/.cache/.evolution/mail/
for i in `find . -name folders.db`
        echo "Rebuilding Table $i"
        sqlite3 $i "vacuum;"

Thank you Patrick, I ran the script but the problem still 
the way, the correct path for me was 

instead of

Good catch. I was cutting and pasting from an old script.

Perhaps, would the erase of the entire content of that folder be 
good idea?

You can delete anything in ~/.cache/evolution and it will be 
so there's no harm in trying.

I tried (removed the whole ~/.cache/evolution, which has been rebuilt 
the following run) but the problem still happens... What else could I

Firstly, did the database cleanup have any effect on the "no such
table" message? You didn't say.

I went back and read your original message. I hadn't noticed that the
problem is related to a Gmail account. Two things come to mind:

1) Check (using the Gmail web interface) that the folders are enabled
for IMAP using the "Show in IMAP" box for each label under
Settings/Labels. And of course make sure the folders are subscribed to
from Evolution (I know you said they were, but check).

2) Was your account configured using Google Online Accounts? If not,
you might want to reconfigure it, i.e. delete the account from Evo and
re-create it using GOA.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]