Re: [Evolution] Restoring addressbook after doing a 3.8.4->3.11.3->3.8.4 'cross-grade'

On Mon, Jan 13, 2014 at 06:04:46PM +0100, Milan Crha wrote:
On Fri, 2014-01-10 at 11:37 -0500, John Affleck wrote:
For various reasons, I recently upgraded (on ubuntu 13.10, which I guess
explains some of the reasons) from the 'stock' 3.8.4 to 3.11.3 and then
back to 3.8.4. Everything worked out fine, except I now have lost access
to my address books:

This address book cannot be opened.  Please check that the path
exists and that permissions are set to access it.

Detailed error message: Unable to connect to 'Personal': Error
introspecting unknown summary field 'file_as_localized'

..which makes me a little sad. Is there a way to 'recover' from that ?
I don't mind performing somewhat random sqlite3 operations on
contacts.db, but I don't see anything that looks like file_as_localized.

["hard way" deleted]

[1] Another option is to concatenate values of "vcard" column of
"folder_id" table into one long file, which may produce quite the same
result as the "Save as vCard" function, and then import the concatenated
file after local data being moved away.

Woo! Thanks! That worked perfectly! Or as close to perfectly as I
mv  ~/.local/share/evolution/addressbook ~/.local/share/evolution/addressbook.bak
sqlite3 ~/.local/share/evolution/addressbook.bak/1306861082 2878 0 jafflec-VirtualBox/contacts.db 'select 
vcard from folder_id' > /tmp/old_contacts.vcf

..and then I just imported the resulting .vcf file into the old, (now
empty) address book. And all of my contacts are back!

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]