Re: [Evolution] Evolution

On Wed, 2014-04-16 at 11:57 +0200, Ralf Mardorf wrote:
On Wed, 2014-04-16 at 11:27 +0200, Milan Crha wrote:
it would be really helpful if you could be more specific

Please read:

OK, I copy&pasted the problems (quoted as '>>' below):

Evolution asked again and again for the password of one account, even
when I didn't send or retrieve mails, it wasn't add to the keyring.

After downgrading the password issue is solved.

Evolution depends on libsecret with password storing or reading, which
means it doesn't talk to gnome-keyring anymore. The libsecret interface
can be implemented by any desktop, thus for example in GNOME you store
passwords in gnome-keyring, while KDE can store passwords in KWallet
(whether it does it already or not I cannot tell for sure, I od not use
KDE, but there is the possibility). I cannot explain the reason, but it
seems the libsecret library has a trouble with that password for some
reason. If you store to the gnome-keyring, then seahorse can show you
the list of stored password. An interesting test would be to get rid of
one of other passwords, whether you'll be prompted for it multiple times

By the way, is the account an IMAP+ account? The 3.12.1 contains a
change where were added concurrent connections. That means that
evolution connects to the server multiple times, and each connection
requires the password. There is always done at least one connection when
you run evolution, to get list of folders and so on. Another connection
is started (or used an old one), when an automatic update is started, if
you have it set for the account.

Evolution kept the send and receive window after finishing all

After downgrading the send and receive window doesn't hang anymore when
the processes are finished, this btw. didn't happen always.

It sounds like evolution didn't think it's over yet. getting a backtrace
of evolution in that state may help to see what it actually does.

Evolution never finished processes, this btw. happens after downgrading
to the previous version, now for the previous version too, so
downgrading to/keeping just

evolution 3.10.4-1
evolution-data-server 3.10.4-1
gnome-desktop 1:3.10.2-1

doesn't solve all issues.

After downgrading sometimes an action still won't finish and e.g. cause
empty and/or unresponsive windows. Before downgrading it sometimes tried
to connect never-ending to a server. I could use Evolution, but the
"receiving" message in the status bar continued without an time-out,
without an end.

Aah, with 'processes' you mean 'actions' aka something what evolution
tried to do but that never-ending wait for a response from a server
happened and the actual action was kept "running" ad infinity. I'd say
it's due to unexpected connection issues. The 3.12.1+ should behave
better in this regard, identifying connection issues per account, rather
than for whole evolution. I noticed in the recent past also a claim
about IPv6 being used in the background for name resolution, which can
be related, if evolution was trying to reach the server on an IPv6
connection, which wasn't a real active connection at all.

Just a wild guess, after you updated evolution, you also updated
evolution-data-server and other related evolution packages with it,
right? Did you also restart the machine after the update, or you left it
running? As you move between versions, it is a good idea to also restart
background evolution processes (ps ax | grep evolution), to get used the
new versions instead of the old. Mixing the versions in the runtime may
cause weird behaviour, like the one with passwords, I think.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]