Re: [Evolution] Evolution does not decrypt PGP emails

On Sun, 2013-06-02 at 22:35 +0100, huw wrote:
On Fri, 2013-05-31 at 14:41 -0400, Adam Tauno Williams wrote:
On Wed, 2013-05-29 at 08:42 +0100, huw wrote:
On Tue, 2013-05-28 at 16:34 +0100, huw wrote:
Possibly, you do not see something like -
/usr/bin/gpg-agent --sh --daemon
--write-env-file /home/awilliam/.gnupg/ /usr/bin/ssh-agent /etc/X11/xinit/xinitrc
which i have in my task list, assuming it was created by
/usr/bin/dbus-launch --sh-syntax --exit-with-session /usr/bin/gpg-agent
--sh --daemon
--write-env-file /home/awilliam/.gnupg/ /usr/bin/ssh-agent /etc/X11/xinit/xinitrc
I've gone to great lengths (long story) to install an entirely different
distro - OpenSuse in this instance - to start all over again, and

I'm on openSUSE 12.3, it works for me.  It has always worked for me.

Evolution is still not decrypting my emails despite asking for my
passphrase.  I would be enormously grateful for any help you or anyone
else can provide.

Do you have your key set in Edit -> Accounts -> Mail Accounts ->
{account} -> Security : OpenPGP Key ID ?

If you run seahorse [Passwords & Keys] is your key listed?  The "Key ID"
there matches the one you have set in Evolution?

In reply to your message, the output of...
ps -ef | grep agent
...finds nothing.  Where do I start?

Either (a) you do not have a key set, (b) GPG support is not installed,
or (c) the gnome-session is not starting the agent.

In gnome-session-properties "Startup Programs" is "Certificate and Key
Storage" listed and enabled, as well as the "GPG Password Agent"?

Adam Tauno Williams <>
System Administrator, OpenGroupware Developer, LPI / CNA
Fingerprint 8C08 209A FBE3 C41A DD2F A270 2D17 8FA4 D95E D383

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]