Re: [Evolution] Evolution does not decrypt PGP emails

On Fri, 2013-05-31 at 14:41 -0400, Adam Tauno Williams wrote:
On Wed, 2013-05-29 at 08:42 +0100, huw wrote:
On Tue, 2013-05-28 at 16:34 +0100, huw wrote:
Hi all
I've just started using Evolution.  I can send emails encrypted (and
signed) just fine, but when my friend sends me emails encrypted with
PGP they are not decrypted by Evolution.  I get the dialogue asking
for my passphrase, which I duly enter, then the email displays in an
encrypted format anyway.  Any ideas?
I know it isn't a problem with my GPG setup, as it was working in
Kmail2 (which I've just switched from) and I can copy the encrypted
text to a text file and decrypt it in a console.  The problem surely
lies within Evolution.
Some more info which may help.  Someone on the Sabayon forum is
helping me to troubleshoot this.  He's asked whether gpg-agent is
running.  If I run the command myself it insists it's running and
available, however I cannot find any instance of it using the ps
command, and I cannot find the gpg-agent.conf file referenced in its
man page.  Could this be the problem?

Possibly, you do not see something like -

/usr/bin/gpg-agent --sh --daemon
--write-env-file /home/awilliam/.gnupg/ /usr/bin/ssh-agent /etc/X11/xinit/xinitrc

which i have in my task list, assuming it was created by

/usr/bin/dbus-launch --sh-syntax --exit-with-session /usr/bin/gpg-agent
--sh --daemon
--write-env-file /home/awilliam/.gnupg/ /usr/bin/ssh-agent /etc/X11/xinit/xinitrc

Hi Adam

I've gone to great lengths (long story) to install an entirely different
distro - OpenSuse in this instance - to start all over again, and
Evolution is still not decrypting my emails despite asking for my
passphrase.  I would be enormously grateful for any help you or anyone
else can provide.

In reply to your message, the output of...

ps -ef | grep agent

...finds nothing.  Where do I start?

Kind regards,

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]