Re: [Evolution] [Fwd: Re: local mail spool still unaccessible with evo 3.4.4.-1]

I'm just saying the when I created the new mbox file account after
removing the old, this directory was created, containing these files.

Yes, because Evo needs somewhere to store the indexes for that account.

The pop account I have is also having a strange name, but that directory
contains: folders.db, uid-cache and a subdirectory cache containing the
actual mail files (in maildir format?).

POP needs a different set of internal files, which is stored in that

And the "strange name" is actually the UID of the account within Evo,
which you will be able to see at the beginning of the line from gconf.

Have you actually looked to see if the actual spool file is accessed at

How to know if evo tries to accesses it? logcheck is reporting there so
this spool file is updated often.

inotifywatch will tell you when a file is accessed (by anything).

    strace -f -e trace=file evolution

Will give you an output of every single file that Evolution accesses -
pipe the output of the command to a file then use grep to see if the
file you want is being accessed.

Note though, the file will NOT be updated because you haven't
changed anything in it.

Evo is reporting several thousands of mails available  but cannot find
the mails themselves.

Is there actually that many messages in the spool file?

Have you even tried running Evolution from the command line to see if
there are any errors reported?  Have you tried doing it with debugging
turned on?

From command line yes. That is where the message below comes from:
(evolution:8019): evolution-mail-WARNING **: Failed to refresh folders:
Error storing 'mailbox: /<username>/INBOX (spool)': Summary and folder
mismatch, even after a sync

I have also been running evo with debugging before, but forgot it by
now. (It's not the first time there are problems with evo) How to enable
debugging info?

to see it. These chunks of XML are sometimes difficult to sort out, but
you are looking for a line that starts "<account name="nameofaccount"".
In that line there should be a section looks like
<url>spool:/var/mail/username</url> - do you see that?

Yes I see it now: <url>spool:///var/mail/"username"</url>
It seem to be correct, why does not evo find it?

Does it really have three slashes in the URL?  Does it have three
slashes in the configuration within Evolution?  Because it doesn't on my
system.  Perhaps that is confusing things.

Yes, there are three slashes. The pop and imap accounts has two! Can I
edit that in some easy way, using gconftool-2? Or can I edit the 
%gconf.xml file directly?

Does the config within Evolution have three slashes?  Can you change it

If you need to play with the gconf entries, use gconf-editor


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]