Re: [Evolution] Evolution EWS just shows one authentication method

Tried the version that came with Ubuntu and also 3.4.1 and 3.5.1 and
all of them with the same problem.
I got stuck on the authentication part.

You do realise that the odd number releases (i.e. 3.3.x, 3.5.x, etc.)
are development releases and not meant for production use?

I can understand that sometime the server doesn't show all the
authentication types for you and my check for supported types doesn´t
work on all versions I tested On the Authentcation Type, it just shows
me one type of authentication (Password) and no others..
I ran Evolution with EWS_DEBUG=2 and when I try to authenticate on the
server it gives me unauthorized with error code 401. Trying the URL on
a browser works fine. I even found a script that would connect via
curl. I tested the script with authentication basic and ntlm. It works
on basic but not on NTLM.
Am I missing something here?

As a user of Evolution EWS (i.e. not a developer) I have found that
finding the required URL is a bit of a dark art.  It doesn't necessarily
follow that the URL you use is the same as the one for logging in to
OWA.  This is almost certainly not the fault of Evolution EWS, but more
the arcane and obscure setup of complex Exchange systems.  For instance
the Exchange 2010 server I use has a web access URL of (real names changed to protect the guilty),
whereas the EWS URL is

And then there's the username required - my external email address is of
the form 'first last unit domain uk', I login to the OWA interface with
my "real" username of, say, 'unmame', but the EWS config requires my
username there to be 'uname host domain uk'.  Again, I don't think this
is really a failing of Evolution EWS, but more a symptom of how Exchange
is setup.

All I can say is that once it's setup correctly, it works well.  All I
need now is shared calendar access ...


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]