[Evolution] Evolution EWS just shows one authentication method


I've been trying all day to make Evolution with Evolution-ews work with a hosted Exchange Server with no luck.
Tried the version that came with Ubuntu and also 3.4.1 and 3.5.1 and all of them with the same problem.
I got stuck on the authentication part.

I can understand that sometime the server doesn't show all the authentication types for you and my check for supported types doesn´t work on all versions I tested On the Authentcation Type, it just shows me one type of authentication (Password) and no others..
I ran Evolution with EWS_DEBUG=2 and when I try to authenticate on the server it gives me unauthorized with error code 401. Trying the URL on a browser works fine. I even found a script that would connect via curl. I tested the script with authentication basic and ntlm. It works on basic but not on NTLM.
Am I missing something here?

I am running Ubuntu 12.04, the exchange server is 2010 and my evolution (ews/data-server and main) are all 3.5.1 but, as previously said, I have tried with other versions with the same outcome.

I do appreciate any help/guidance.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]