[Evolution] Evo 2.26.1 + message from Hotmail with attachments + forwarding, seems to result in lost JPEG attachments

Hi all,

Is this a known bug? I've searched bugzilla, but can't see it, yet it
seems odd, so I'm assuming someone must have seen it before. Details as

I have an HTML email that I have received, with 7 attachments (i.e.
Evolution says "7 attachments" and then has the "Save All" button, and
at the end of the email there are 7 attachment items I can do various
things to). There are also some inline html-img-tag images in the HTML
message (as part of someone's signature), but I don't care about those.

For the 7 attachments:
* One of these attachments is word .doc file.
* One of these attachments is a PDF file.
* The remaining 5 attachments are all JPEG images.

I can view all these attachments fine in the original mail (by going
"Open in OpenOffice.org Word Processor..." for the .doc, "Open in
Document Viewer..." for the PDF, and "View Inline" for the JPEGs).

So far, it's all good. Now I try to forward this email, by clicking the
"Forward" button, and the weirdness begins.

Forwarding changes the message format to plain-text (since that's my
preference), _but_ the message now has just 2 attachments - the .doc and
the .pdf. The 5 JPEG attachments have simply vanished.

I have tried changing my default outgoing mail format to HTML (by going
Edit -> Preferences -> Composer preferences -> "General" tab -> tick
"Format messages in HTML"), and have tried forwarding this way, and
whilst it is definitely now an HTML email, I still only see the same 2
attachments, and the 5 JPEGs are still missing.

I have tried sending the mail to myself through evolution to see if I
really do only get two attachments (in case the 5 images are actually
attached but just aren't showing), and I really do only get the 2

I have restarted evolution (File -> Quit, then start Evo again), in case
that was the problem, and have then retried sending the message to
myself, but it makes no difference, still only 2 attachments.

There are spaces in the name the .doc file, but the PDF and the JPEGs do
not appear to have any spaces in their names.

The server I'm using is gmail (for both the received mail and the server
I'm trying to forward it through) - receiving by IMAP, sending by SMTP.
Evolution version is 2.26.1, distro is Ubuntu 9.04

I have logged into gmail's web interface, and it shows an attachment
icon, and I can view the 7 attachments there too. I have then forwarded
myself this message through gmail's web interface and it appears fine,
with all 7 attachments when viewing the self-forwarded message I receive
(in both gmail and in Evolution). So as far as I can tell from this
test, this is an Evolution problem.

The only other weird thing is that in Evolution's list of messages, that
the original message does not have a paper-clip icon to show that it has
attachments, which seems a bit weird, as all other messages with
attachments do.

The original message was sent from a hotmail account, and I can be
certain that the person who sent it didn't intentionally try to do
anything weird or mess with the headers or anything (the sender is my
sister, and her interest in computers or software is basically zero) -
the attachments would I presume have been added using hotmail's standard

Also, if I forward myself the message through gmail's web interface, and
then in turn forwarded that forwarded message to myself using Evolution,
then that works fine, and has all 7 attachments.

So based on the above, the common factors seem to be: Email with
multiple attachments including some JPEGs, sent from Hotmail, forwarded
using Evolution, results in lost JPEG attachments.

Anyone else seen this or anything like it, or should I log a new bug?

-- All the best,

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]