[Evolution] Inbox Expunge Fails with a solution


I had a quite old Inbox (835 MB worth). When I upgraded to Fedora 10,
expunging my Inbox started to fail. Evolution would spin it wheels for
quite some time and finally report the expunge had failed.

I tried to split my Inbox up into messages from 2000-2008 and leave only
2009 messages in my Inbox. Even so Evolution still failed to expunge the
Inbox. So I set the problem a side to solve at a later date.

The later data came along and I remembered "mutt" a command line e-mail
client is really good at manipulating the mail box format that my Inbox
is in. So I closed Evolution, "evolultion --force-shutdown" and I opened
my Inbox with mutt. "mutt -f ~/.evolution/mail/local/Inbox".

In mutt I simply deleted all the e-mails from 2000-2008, because I had
moved those to another Inbox. I simply saved the Inbox back to disk
without the deleted messages and quit mutt.

I then re-opened the Inbox with Evolution. I tried to Expunge the much
smaller Inbox (250 MB). It failed again but much quicker. I then had the
bright idea to delete the Inbox index files (Inbox.ibex.index and

I then re-opened Evolution and the expunge was successful. So far the
Inbox has expunged successfully for several days.  If someone else
suffers from the problem, I hope this technique is useful for them to
resolve their problem.

Of course, I would love to hear about an easier solution to this problem
using only evolution utilities or widely available command line tools.

Thank you,

Rob Seward
Bluestone Consulting Group, LLC

web:     http://www.bluestone-consulting.com/
e-mail:  rseward bluestone-consulting com
office:  734.274.5168
mobile:  734.604.3780

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]