Re: [Evolution] Compiling evolution-data-server-2.24.2 error


Seriously appreciate the help.  I am using the export config path and not helping. IF I manually change the 
e-msgport.c file to look for nspr.h in /usr/include/nspr4/nspr.h then it finds it and compiles, but the 
linking fails with....

./.libs/ undefined reference to `PR_GetErrorText'
./.libs/ undefined reference to `PR_GetErrorTextLength'
./.libs/ undefined reference to `PR_Write'
./.libs/ undefined reference to `PR_Read'
./.libs/ undefined reference to `PR_CreatePipe'
./.libs/ undefined reference to `PR_Close'
./.libs/ undefined reference to `PR_GetError'
collect2: ld returned 1 exit status
make[2]: *** [test-source-list] Error 1

Any thoughts on this?  



----- Original Message ----
From: Patrick O'Callaghan <poc usb ve>
To: Anthony Wolfe <aw_wolfe yahoo com>
Sent: Friday, December 19, 2008 3:53:59 PM
Subject: Re: [Evolution] Compiling evolution-data-server-2.24.2 error

On Fri, 2008-12-19 at 13:19 -0800, Anthony Wolfe wrote:

Thanks for the input. I've tried the --with-snpr-include= to no avail, still get identical error.(making 
sure I've done make clean between each attempt) I've also tried creating a soft link nspr -> nspr4 but it 
still isn't finding it.  Do I need to include libraries as well?  Any input would be appreciated.  Is there 
any chance that this error is being caused by something else?

Have you set and exported PKG_CONFIG_PATH? You should do this first (and
do everything else from the same Shell session of course). I use:


This is what I use for configuring e-d-s:

./configure --prefix=/opt/evolution --enable-nss --with-openldap --with-nspr-include=/usr/include/nspr4

There are full instructions in the README file in the evolution source
directory (though not in the e-d-s directory last time I looked).

You can also use Paul Smith's script
( which builds from SVN, but it's
designed for Debian and I use Fedora.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]