Re: [Evolution] Evolution missing folders--subscribed only?

On Friday 25 May 2007 22:26, Ross Boylan wrote:
On Friday 25 May 2007 11:47, Patrick O'Callaghan wrote:
Have you tried Folder->Subscriptions<select server>->Refresh?


That does show a list of all my folders.  However, when I try to subscribe
to one, I get the message, e.g.
Cannot subscribe to folder `INBOX/pol': Invalid mailbox name
I'm guessing that the problem is the separator, since my server wants names
like INBOX.pol.  However, I don't see any way to change the separator.
Wrong guess.  The real problem was that INBOX.pol was not a folder.  It has 
subfolders like that are real folders, however.  This somewhat 
suprising behavior of have names without folders is how Cyrus does it, and 
appears consistent with the IMAP spec.

While trying to get this to work I unsubscribed to everything.  That
operation seems to have taken, so now I see my INBOX only, with no
subfolders, in the left hand pane of the main window.
This problem persists, even with refreshes and restarts.  Any ideas?

And, again, my original goal was just to see all my folders, regardless of the 
subscription status.  Any way to do that?


One bit of new news below, for the record.

On Fri, 2007-05-25 at 11:14 -0700, Ross Boylan wrote:
Evolution is only aware of some of the folders on my IMAP account.  My
 efforts to get it to start over haven't worked.  Can anyone advise me
what I need to do to get the list of folders accurate?

The folders showing appear to be the ones I'm subscribed to; checking
and unchecking the "show only subscribed folders" option (which was
originally off anyway) doesn't change the display.

I have a weird, incomplete list of subscribed folders on the server
because (probably) of another email client (icedove aka thunderbird)
that died while working with the mailbox.  icedove shows the same list
of folders as evolution.

I want to see all folders, not the small subset that seems to have been
 marked subscribed.

I tried deleting (renaming, actually) .evolution,
.gnome2_private/Evolutioin, and .gconf/apps/evolution.  I tried
evolution --force-shutdown.  I tried asking it to send/receive mail,
though I interrupted that because it was taking forever.  I tried
deleting and recreating the account (in evolution).

I have not done alll these things at once.  For example, when I renamed
the files I quit evo, but did not --force-shutdown or stop gconfd
(which means, I think, that it held onto some some old settings in
memory. However, it doesn't appear to have any settings that list
particular folders.)

I do not know what a good way to shutdown gconfd is, short of logging
out. My understanding was that it was supposed to shut down after a
couple of minutes of inactivity, but it doesn't do so (could it be
waiting for one of the evo sessions I killed to tell say it's done?).
gconftool-2 --shutdown
seems to do it, though I'm still not sure why it doesn't shut itself down.

I have over 100 folders, some nested within others.  The largest folder
has about 340,000 messages.  My server is running Cyrus 2.2 (locally).

When I first created the accounts my version (Debian 2.6.3-6) was
suffering from (though
with different symptoms: after I created the account the process of
opening folders hung and I got the error message shown in the bug in my
.xsession-errors).  I rebuilt with the fix
g- gnom e-new-mail-notify.eplug.xml?r1=33354&r2=33530.

It is possible there were other problems as well, since I got other
errors (see at bottom of message and

Here's the .xsession-errors corresponding to my original account
creation: --------------------------------------------------------
CalDAV Eplugin starting up ...
libnm_glib_nm_state_cb: dbus returned an error.
  (org.freedesktop.DBus.Error.ServiceUnknown) The name
org.freedesktop.NetworkManager was not provided by any .service files
X Error: BadWindow (invalid Window parameter) 3
  Major opcode:  19
  Minor opcode:  0
  Resource id:  0x3c07458

(evolution-2.6:6600): e-utils-WARNING **: Cannot resolve
symbol 'org_gnome_new_mail_config' in
plugin '/usr/lib/evolution/2.6/plugins/'
(not exported?)
BBDB spinning up...

(evolution-2.6:6600): evolution-mail-WARNING **: Cannot activate

(evolution-2.6:6600): e-utils-WARNING **: Cannot resolve
symbol 'org_gnome_new_mail_config' in
plugin '/usr/lib/evolution/2.6/plugins/'
(not exported?)

(evolution-2.6:6600): evolution-mail-WARNING **: Cannot activate

(evolution-2.6:6600): Gtk-CRITICAL **: gtk_list_store_get_path:
assertion `iter->stamp == GTK_LIST_STORE (tree_model)->stamp' failed
-- ---- (the ones I fixed concerned org_gnome_new_mail_config.
 Suspiciously, this seems to be triggered by the receipt of new mail,
not the creation of an account).

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]