Re: [Evolution] Evolution Suddenly Stops Working?

Sushma Rai wrote:

Can you try to get the gdb traces when it stops working.


On Wed, 2005-10-26 at 07:19 +1000, Paul Trevethan wrote:

I have been happily chugging along here using Evolution 2.4 on Ubuntu
'Breezy' for a few weeks now without any problem.

Suddenly the other day it stopped loading?!

I have tried loading from the icon on the taskbar that I set up, as
well as from the menu and from a terminal command line. Nothing works!
No errors from the command line - it just returns a prompt.

I have re-installed all 'evolution' related files using Synaptic and I
have tried moving my $HOME/.evolution out of the way to see if it would
start anew. Nothing! Nothing I have tried gets any different result.

There have been no crashes of the machine and everything else continues
to work as normal.

Is this what you wanted? I have never used debugging stuff before?! I simply followed the instructions on the web page as best I could:-

(no debugging symbols found)
(no debugging symbols found)
---Type <return> to continue, or q <return> to quit---q
Error while reading shared library symbols:
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1230853312 (LWP 14492)]

Program received signal SIGINT, Interrupt.
[Switching to Thread -1230853312 (LWP 14492)]
0xffffe410 in __kernel_vsyscall ()
(gdb) thread apply all bt

Thread 1 (Thread -1230853312 (LWP 14492)):
#0  0xffffe410 in __kernel_vsyscall ()
#1  0xb79370bd in poll () from /lib/tls/i686/cmov/
#2 0xb6b43348 in g_main_context_iterate (context=0x809f008, block=1, dispatch=1,
    self=0x806f2e0) at gmain.c:2867
#3 0xb6b439d8 in IA__g_main_context_iteration (context=0x809f008, may_block=1)
    at gmain.c:2624
#4  0xb723b1da in link_main_iteration () from /usr/lib/
#5  0xb72203b5 in giop_recv_buffer_get () from /usr/lib/
#6  0xb7223a4a in ORBit_small_invoke_stub () from /usr/lib/
#7  0xb7223c1d in ORBit_small_invoke_stub_n () from /usr/lib/
#8  0xb7235439 in ORBit_c_stub_invoke () from /usr/lib/
#9  0xb7f2572e in GNOME_Evolution_Shell_createNewWindow ()
   from /usr/lib/evolution/2.4/
#10 0x08060c0b in es_menu_hook_get_type ()
#11 0xb6b42750 in g_idle_dispatch (source=0x82585c0,
callback=0x8060983 <es_menu_hook_get_type+799>, user_data=0xfffffffc) at gmain.c:3813 #12 0xb6b404ee in IA__g_main_context_dispatch (context=0x809df68) at gmain.c:1934 #13 0xb6b434f6 in g_main_context_iterate (context=0x809df68, block=1, dispatch=1,
    self=0x806f2e0) at gmain.c:2565
#14 0xb6b437e3 in IA__g_main_loop_run (loop=0x8256570) at gmain.c:2769
#15 0xb72bb590 in bonobo_main () from /usr/lib/
#16 0x08061324 in main ()
(gdb) Quit

Hope this helps you help me? It means nothing to me?

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]