[Evolution] Re: evolution 2.2.2 and uw-imapd problems

Not Zed wrote:
- I override the imap namespace to the typical "mail/" (which should
refer to ~me/mail/ on the server); when I'm subscribing to folders,
get an extra level/entry, which is all blank space, as a child of
"mail"; I don't get this under thunderbird, and there is nothing in
that directory that I can think of that would cause this... odd

Try without the trailing / maybe.  Not something i've seen before.

I tried this (i.e., using "mail") with same results.  

I then tried something else: instead of subscribing and showing only
subscribed folders, I simply show all folders.  This is a decent
workaround for me, for the time being, as it circumvents the two
problems I had.  Annoyingly enough, even in this approach, there is a
blank folder listed in the folder hierarchy on the left, but it is on
the same level as my other leaf folders, rather than being at an
intermediate level between "mail" and the actual folders containing

Furthermore I checked my ~/mail directory on the server... the folders
listed in evolution are precisely the ones in ~/mail... no more, no
less, and none of them have any funky names which could be misparsed
and lead to detection of multiple boxes.

As far as I know everything is as it should be on the server side, and
evolution is picking up some weird folder.

- once these folders do show up, they are listed twice each in the
folder tree! is this a bug or some misconfiguration on my part? 
browsing of these folders does work though...

Hmmm, you're probably subscribed to them twice somehow, but with
different path-names.  So they're not matching and it thinks they are
unique.  This is just a guess, the output of LSUB would show for
certain; I would check that.  Although the imap code has plenty of
and this may be one of them, it should work fine with uw-imapd if it
configured properly.

Is there any way to do this (LSUB) from within evolution?  My IMAP
server only supports SSL connections (i.e., no unencrypted
connections), hence I don't think I'd be able to talk to it manually
using telnet...

What I can tell you is that the IMAP server thinks I'm only subscribed
to the folders *once*.  This is uw-imapd server, and it records the
subscribed mailboxes in ~/.mailboxlist .  Looking at this file after
subscribing from evolution I see that each folder is subscribed only
once, as its supposed to.

Another datum: Thunderbird handles the IMAP subscriptions properly on
this server; when I look at *its* subscriptions in ~/.mailboxlist, it
is using names like "~/mail/foo", rather than my current evolution's
"mail/foo".  Changing the namespace override from "mail" to "~/mail"
causes "Very Bad Things"(TM) in evolution.  First, in the subscribe
dialog, the scan for folders never completes, although it lists all the
folder present (the throbber/spinner keeps going indefinitely). Second,
subscribing doesn't quite work: after closing the dialog one gets an
error about IMAP, and only the first selected/checked folder gets
subscribed. Also almost all IMAP interactions with this setup cause
IMAP errors in evolution.  Besides, the folders are properly accessed
using just "mail/foo", other than the duplication (which probably
happens with "~/mail/foo" as well)

Another datum: the server is running UW-imapd from the Debian distro;
in particular it is using the package "uw-imapd-ssl" version
"2001adebian-6".  (I don't have admin privilidges on the server)

Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]