Re: [Evolution] Evolution addressbook

I had already looked there but there was nothing. Actually I did a lot
more testing last night and the behaviour is weird. The original cause
was Evolution just stopped and when I restarted the addressbook was
gone. I've tried overwriting the db file in addressbook/local/system but
it gets overwritten by the new (post crash) version. So it now seems to
me that the new version must be cached somewhere. I've tried stopping
evolution and then:
touch now
start evolution and edit addressbook and then stop evolution
find . -newer now -print
and this reveals either: next to nothing has changed,
addressbook.db.summary has changed or once a temporary directory had
been created when I added a new address book. So is it possible that the
database is being cached in memory by one of the other evolution
processes that is still running when you stop the main process? I'm
going to try shutting down gdm and then overwriting the addressbook file
and then restarting. Wish me luck.
On Thu, 2005-01-20 at 22:49 -0500, JP Rosevear wrote:
On Thu, 2005-01-20 at 18:39 +0000, Keith Blow wrote:
I've just upgraded to Evolution 2.0.3 and after a couple of days of
running it has trashed my addressbook. Built up over the last six years,
I am very unhappy. I can't find out where the addressbook in the new
version is stored. Anyone know? If it is in the same .db format as the
1.4 version I can then replace it with my backup.

Its in .evolution/addressbook/local/system (if its the "personal" one).
What happened during the thrashing? Did your machine crash and it didn't
recover properly?  It might be possible to just remove some meta data
files for the .db file.


Attachment: signature.asc
Description: This is a digitally signed message part

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]