Re: [Evolution] Evolution does not prompt for new password

There is a problem with my Evolution 2.0.3 on Mandrake 10.1 Official (upgrade 
from 10.0). My password has been reset for one of my accounts, but Evolution 
does not prompt me  to enter the new password.  Evolution just shows the 
"send & receive mail" dialogue, saying "waiting" for a few seconds, after 
which it disappears. Meanwhile, ethereal shows what happens:

Response: +OK POP3 server ready
Request: CAPA
Response: +OK Capability list follows
Request: USER myusername
Response: +OK User name accepted, password please
Requst: PASS myoldpassword
Respones: -ERR Bad login
Request: CAPA
Response: +OK Capability list follows
Request: LIST
Response: -ERR Unknown AUTHORIZATION state command
Request: UIDL
Response: -ERR Unknown AUTHORIZATION state command
Request: QUIT
Response: +OK Sayonara

Small relevant excerpt from CAMEL_DEBUG:

CamelException.setv(0x8a8a7f0, 304, 'Unable to connect to POP server 
Error sending password: -ERR Bad login')

Authentication type of the account is set to "password".

Does anyone know why Evolution drops the error? Is there a 
practical workaround for this? Note that I have already tried removing the 
account and re-adding it in the account settings.

Did you try Actions / Forget Passwords?

Evolution not prompting for a new password at all on bad login actually
should be worth filing a bug, but I believe this is already filed -- at
least I remember coming across this issue a couple of times. Forgetting
Passwords solved it. :)


char *t="\10pse\0r\0dtu\0  ghno\x4e\xc8\x79\xf4\xab\x51\x8a\x10\xf4\xf4\xc4";
main(){ char h,m=h=*t++,*x=t+2*h,c,i,l=*x,s=0; for (i=0;i<l;i++){ i%8? c<<=1:
(c=*++x); c&128 && (s+=h); if (!(h>>=1)||!t[s+h]){ putchar(t[s]);h=m;s=0; }}}

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]