Re: [Evolution] Spell checker

Yes, I am sorry. I just ran it again and yes I did see "MISSINGNAME"
right abot spelling.
here is how it looks like:

On Tue, 2005-01-04 at 14:21 -0500, Jeremey Wise wrote:
I was refering to withing "gnome-spell-properties-capplet" which had the
top left pane listed as "MISSINGNAME" which I believe is not a good
thing... I do not have another SUSE box so I do not know for sure if
this is the case.

On Tue, 2005-01-04 at 14:02 -0500, Genady Perchenko wrote:

when I tried to add the word to the dictionary, Evolution just crashed. 
I am not sure I understand your second question though. What menu are we

On Tue, 2005-01-04 at 12:35 -0500, Jeremey Wise wrote:
Does your system hang if you try to add a word to the dictionary?

Did your menu option show up as 'MISSINGNAME'?

On Tue, 2005-01-04 at 11:31 -0500, Genady Perchenko wrote:
You know, you will not believe  it, but just this morning before I got
this email, I did exactly same steps as described in the link. And yes!
as of this morning I have my spelling back! I am happy camper now!!

Thank you!    

On Tue, 2005-01-04 at 10:07 -0500, Jeremey Wise wrote:
Don't know for sure if this is related or what you are looking for but
this is what I had to do in evolution to get spelling to work. Like
yourself I had all packages installed but I could not get spell checking
to work.

As it states this is not a fix as you can not add any 'user defined'
words (hangs the entire system hard) but it will do basic spell

On Sat, 2005-01-01 at 23:27 -0500, Genady Perchenko wrote:
I added gtkspell as it was not on originaly. Now it looks like this:

enady igrushka:~> rpm -qa|grep spell| sort

still no langs listed in the spell options window. 

On Sat, 2005-01-01 at 23:31 +0100, Andre Klapper wrote:
Am Donnerstag, den 30.12.2004, 12:25 -0500 schrieb Genady Perchenko: 
genady igrushka:~> rpm -qa | grep aspell

for your interest, i'm running 9.2, spell checking works fine and i've
got the following:

andre embrace:~> rpm -qa|grep spell

perhaps this helps you a bit.
there's also a guide by mark gordon for needed rpm's for spell checking
with evolution 1.4 which i will quote below.


"Spell checking is one of the more complicated features in Evolution
from a standpoint of release engineering and package management.
Evolution uses a set of libraries for spell checking, some of which are
used by other applications.  Evolution often requires newer versions of
some of these libraries.  Making packages that work with both Evolution
and older applications can be tricky (hence some of the *spell-compat
packages we've been releasing lately for some platforms).  Additionally,
there's the need to support a wide variety of languages.  All these make
the problem unusually complicated.

The best diagnostic for broken spell checking is to run the following

rpm -qa | grep spell | sort

Then check against the list below.  If anything is missing, install it
via Red Carpet.  If you have further unexplained problems, the output of
the above command should be included in the bug report and/or list post.

Mandrake Linux 9.1:

Red Hat Linux 7.3:

Red Hat Linux 8.0:

Red Hat Linux 9:

SuSE Linux 8.2:

This list is, of course, subject to change as new versions and revisions
are released.

This list provides the basic functionality needed to have spell
checking, but it doesn't necessarily provide the files necessary to
spell check in a particular language.  These files are typically split
out into separate packages, since most machines will only need to carry
out spell checking in a small number of languages.  Support for spell
checking in specific languages is typically added by packages with names
such as aspell-en (for US English), aspell-en-uk (for British English),
aspell-de (for German), etc.  Note that Red Hat includes US English
support in its aspell package, and hence Red Hat users typically won't
need a separate aspell-en package.  With the exception of
English-speaking Red Hat users, you will need to install an aspell-$LANG

Important note for users of non-English languages: our gnome-spell1.0
packages for Red Hat Linux 8.0 and Red Hat Linux 9 don't work with the
aspell-$LANG packages provided by Red Hat.  This is because the version
of gnome-spell1.0 used by Evolution requires an updated aspell which is
not compatible with the aspell-$LANG packages that come with those
versions of Red Hat Linux  Consequently, updated packages from Ximian
will be needed to get spell checking to work in Evolution 1.4 under Red
Hat Linux 8.0 and Red Hat Linux 9 for languages other than English.
These packages are not yet available, but packages for several languages
should be released quite soon, and others are in the works.

To configure the language(s) for which spell checking will be enabled by
default in the composer, go to:

Tools -> Settings -> Composer Preferences -> Spell Checking

This should present a list of languages for which you can do spell
checking.  If a language is enabled, words in the dictionary for that
language will be assumed spelled correctly.  In most cases, users will
want only a single language checked.  Polyglots may want several
languages selected, or they may want to change the list dynamically in
the composer window, which can be done from: 

Edit -> Current Languages

...which presents a similar list of languages.

-Mark Gordon"

evolution maillist  -  evolution lists ximian com

evolution maillist  -  evolution lists ximian com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]