Re: [Evolution] setting font size in message list / folder list? (1.5.93 / Slackware)

On Fri, 2004-09-03 at 20:30 +0200, Andre Klapper wrote:
Am Mittwoch, den 01.09.2004, 19:30 +0000 schrieb Jules Richardson:
I've just got Evo 1.5.93 running on Slackware - the only issue being
that the font size for the message list and folder list is a little on
the large size. Is there anywhere I can change this within Evolution? (I
assume it's a global Gnome setting and for some reason Evo under
Slackware isn't picking the setting up)


if i understood you right, this could be bug 30590:
feel free to add comments... :-)

Ahh, yep that's the critter. I did a lot of digging around earlier, and
it seems to be affecting other distributions too, not just Slackware.

right, long post...

The common cause seems to be if people are running KDE rather than
Gnome, and for some reason *some* apps then (Evo and Mozilla, typically)
ignore the font changes as set by 'gnome-font-properties'. It doesn't
seem to affect everything, though.

In my case I'm not running any desktop environment on the server as I
use Evolution against a remote display, so just have the DISPLAY
variable set. I did run KDE once directly on the server though (under
the same user as I run Evo as).

I'm not sure if Evo thinks I'm not running gnome and so decides to
ignore all system preferences, or if there's some vital gnome process
which I should be running on the server before I launch Evo, or what. 

The more I delve into gnome and X font servers and the like the more I
realise what a complete bloody mess it is though. :-) Trying to work out
how everything ties together is a right nightmare.

For reference, I've tried the following so far:

  Changing fonts via 'gnome-font-properties'. Changes stick there, but
Evo takes no notice of them.
  Changing ~/.gconf/apps/evolution/mail/display/fonts/%gconf.xml -
again, Evo seems to ignore the settings
  Running xfs with the same parameters as on a Redhat 9 system (where
Evo worked fine). Makes no difference.
  Launching /usr/libexec/gnome-settings-daemon, as suggested by a few
archived usenet posts about this. That gives me: "You can only run one
xsettings manager at a time; exiting" which is interesting; even if I
shut everything down apart from the bare minimum console processes so
that there's nothing which could conceivably be an 'xsettings manager' I
still get that message.

'ps' output shows nothing running I wouldn't expect (as remembered when
I had this working on  a RH9 system):

  /usr/libexec/gconfd-2 13
  /usr/libexec/bonobo-activation-server --ac-activate --ior-output-fd=17

The odd thing is that I had this running on a Redhat 9 server against a
remote display  - i.e. no graphical processes running on the server
other than Evo - and it worked fine. So I'm tempted to believe that the
problem against a Slackware server isn't that there's something that
should be running and isn't -that it's more likely to be some
configuration that's screwed up somewhere. 

One thing I've just realised now is that I've never run a gnome desktop
up on this machine, only KDE. I wonder if the first time a full gnome
session runs it writes some config to disk somewhere which I'm missing
and on which Evo depends? I bet I ran gnome once or twice directly on
the old Redhat 9 server, even though it didn't have any gnome processes
constantly running on it...

As for the bug details, I'll do some more poking around and then see if
I can leave summary comments there against that bug (assuming I don't
need to go through a ton of registration crud first!)



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]