Re: [Evolution] Clicking on https: links doesn't work

On Sun, 2004-02-08 at 17:09, guenther wrote:
On Tue, 2004-02-03 at 16:09, Patrick O'Callaghan wrote:
On Tue, 2004-02-03 at 00:26, guenther wrote:

Especially check the GConf keys in /desktop/gnome/url-handlers/http and
/desktop/gnome/url-handlers/https. The GUI only sets the former.

Something like the following commands should get you going (untested
though, as I don't have Gnome 2.4 here):

$ gconftool-2 --set --type=string /desktop/gnome/url-handlers/https/command 'mozilla %s'
$ gconftool-2 --set --type=bool /desktop/gnome/url-handlers/https/need-terminal false
$ gconftool-2 --set --type=bool /desktop/gnome/url-handlers/https/enabled true

OK, did all that. However Gnome seems to have decided to ignore
anything I say to it. The gconftool-2 tool does correctly set 
.gconf/desktop/gnome/url-handlers/http/%gconf.xml (NOTE: at the
moment I'm trying to get http working again, before moving on
to https). I can verify this via:

gconftool-2 -R /desktop/gnome/url-handlers

However if I look at it via gnome-control-center, I just get the
same old values as before and no amount of clicking, typing, closing,
opening, restarting etc. makes any difference.

Well, sounds like an issue not related to Evolution at least. ;)

It's tangentially related in the sense that Evo depends on Gnome,
but otherwise I pretty much agree with you.

Have you tried setting the value using the Gnome Control Center and
grepping for that string? Where does it end up?

The *string* itself is set, but it's greyed out. When I hit the radio
button it selects OK, but then I close the panel and open it again and
once more it's deselected.

I know little of the architecture of Gnome, but maybe there's a demon
that's supposed to load the file and report to Gnome apps via CORBA
or whatever, and the demon has died for some reason.

GConf daemon and some Gnome settings daemon, IIRC. But I am not sure
about this. It actually is Gnome 2.4, right?

Yep. Stock Fedora RC1.

Have you ever tried running a Gnome Desktop? Does it work then?

Yes I have, and no it doesn't.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]