Re: [Evolution] Clicking on https: links doesn't work

I had a similar problem at one point:
https:// links opened in Mozilla and http:// links in Galeon.

It turned out that GNOME was treating "https" as "unknown" in the Internet services--
Open the control center, open the file-associations tool, go to the last category, (Web Services or whatever it is) and look in the "Unknown service types" one to see if there's anything there.

Hope this helps...


On Sun, 2004-02-08 at 22:09 +0100, guenther wrote:

On Tue, 2004-02-03 at 16:09, Patrick O'Callaghan wrote:
> On Tue, 2004-02-03 at 00:26, guenther wrote:
> > Especially check the GConf keys in /desktop/gnome/url-handlers/http and
> > /desktop/gnome/url-handlers/https. The GUI only sets the former.
> > 
> > Something like the following commands should get you going (untested
> > though, as I don't have Gnome 2.4 here):
> > 
> > $ gconftool-2 --set --type=string /desktop/gnome/url-handlers/https/command 'mozilla %s'
> > $ gconftool-2 --set --type=bool /desktop/gnome/url-handlers/https/need-terminal false
> > $ gconftool-2 --set --type=bool /desktop/gnome/url-handlers/https/enabled true
> OK, did all that. However Gnome seems to have decided to ignore
> anything I say to it. The gconftool-2 tool does correctly set 
> .gconf/desktop/gnome/url-handlers/http/%gconf.xml (NOTE: at the
> moment I'm trying to get http working again, before moving on
> to https). I can verify this via:
> gconftool-2 -R /desktop/gnome/url-handlers
> However if I look at it via gnome-control-center, I just get the
> same old values as before and no amount of clicking, typing, closing,
> opening, restarting etc. makes any difference.

Well, sounds like an issue not related to Evolution at least. ;)

Have you tried setting the value using the Gnome Control Center and
grepping for that string? Where does it end up?

> I know little of the architecture of Gnome, but maybe there's a demon
> that's supposed to load the file and report to Gnome apps via CORBA
> or whatever, and the demon has died for some reason.

GConf daemon and some Gnome settings daemon, IIRC. But I am not sure
about this. It actually is Gnome 2.4, right?

Have you ever tried running a Gnome Desktop? Does it work then?


char *t="\10pse\0r\0dtu\0  ghno\x4e\xc8\x79\xf4\xab\x51\x8a\x10\xf4\xf4\xc4";
main(){ char h,m=h=*t++,*x=t+2*h,c,i,l=*x,s=0; for (i=0;i<l;i++){ i%8? c<<=1:
(c=*++x); c&128 && (s+=h); if (!(h>>=1)||!t[s+h]){ putchar(t[s]);h=m;s=0; }}}

evolution maillist  -  evolution lists ximian com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]